aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-18 17:30:37 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-18 17:30:37 +0000
commite8d9676b32c5ba2f303678f903673a4d27486d62 (patch)
treea2d5bd8353d2ec29ca8235ee066b42ce10174adc
parent- add bz2 decompression for packages file (diff)
downloadportage-utils-e8d9676b32c5ba2f303678f903673a4d27486d62.tar.gz
portage-utils-e8d9676b32c5ba2f303678f903673a4d27486d62.tar.bz2
portage-utils-e8d9676b32c5ba2f303678f903673a4d27486d62.zip
tweak default CFLAGS
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index e29b1bf8..3a15daaa 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.54 2007/03/05 03:38:06 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.55 2007/04/18 17:30:37 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -15,8 +15,7 @@ WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
$(call check-gcc, -Wsequence-point) \
$(call check-gcc, -Wextra)
-CFLAGS ?= -O2 -pipe
-CFLAGS += -funsigned-char
+CFLAGS ?= -O2 -g -pipe
#CFLAGS += -DEBUG -g
#CFLAGS += -Os -DOPTIMIZE_FOR_SIZE=2 -falign-functions=2 -falign-jumps=2 -falign-labels=2 -falign-loops=2
#LDFLAGS := -pie