aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Torvalds <torvalds@ppc970.osdl.org>2004-11-27 13:29:00 -0700
committerLinus Torvalds <torvalds@ppc970.osdl.org>2005-04-07 21:05:07 -0700
commit073b3c2cca2e596cf230dcd7646050747f7d00d0 (patch)
tree91457387b7acdadd0f2cc8b899b79a3348e69532 /Makefile
parentLeave symbol pseudo usage intact when doing phi-node conversion. (diff)
downloadsparse-073b3c2cca2e596cf230dcd7646050747f7d00d0.tar.gz
sparse-073b3c2cca2e596cf230dcd7646050747f7d00d0.tar.bz2
sparse-073b3c2cca2e596cf230dcd7646050747f7d00d0.zip
Add "memop" simplification phase.
It's a bit more simple-minded than the symbol simplification, and it can be more costly. So we start off with the (cheap) symbol simplification algorithm, and then use this new more generic phase later. This allows us to remove extra loads (and, in theory, stores, but the dead store elimination is so simple-minded right now that it's effectively useless).
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 71373bc..b316889 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ LIB_H= token.h parse.h lib.h symbol.h scope.h expression.h target.h \
LIB_OBJS= target.o parse.o tokenize.o pre-process.o symbol.o lib.o scope.o \
expression.o show-parse.o evaluate.o expand.o inline.o linearize.o \
- sort.o flow.o cse.o simplify.o register.o compat-$(OS).o
+ sort.o flow.o cse.o simplify.o memops.o register.o compat-$(OS).o
LIB_FILE= sparse.a
LIBS=$(LIB_FILE)
@@ -77,6 +77,7 @@ linearize.o: $(LIB_H)
flow.o: $(LIB_H)
cse.o: $(LIB_H)
simplify.o: $(LIB_H)
+memops.o: $(LIB_H)
register.o: $(LIB_H)
sort.o: $(LIB_H)
inline.o: $(LIB_H)