diff options
author | Josh Triplett <josht@us.ibm.com> | 2006-08-29 17:45:20 -0700 |
---|---|---|
committer | Linus Torvalds <torvalds@g5.osdl.org> | 2006-08-29 19:09:31 -0700 |
commit | 38766114c76a469f67df77a2684154e2ca7a1a94 (patch) | |
tree | d290da8f0d1f2824ff94ec63d9a9e7a8fefe24df /Makefile | |
parent | [PATCH] sparse_error() should not silence info() after sparse_error()s (diff) | |
download | sparse-38766114c76a469f67df77a2684154e2ca7a1a94.tar.gz sparse-38766114c76a469f67df77a2684154e2ca7a1a94.tar.bz2 sparse-38766114c76a469f67df77a2684154e2ca7a1a94.zip |
[PATCH] Add backend to graph basic blocks
Add a new backend program which parses the input files, processes them through
the linearization pass, and outputs a graphviz graph of the resulting basic
blocks. Each entrypoint gets labelled by name, but for now the basic blocks
just get labelled with the address of the basic_block structure.
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Signed-off-by: Linus Torvalds <torvalds@osdl.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -21,7 +21,7 @@ CFLAGS += -DDEBUG PREFIX=$(HOME) BINDIR=$(PREFIX)/bin -PROGRAMS=test-lexing test-parsing obfuscate check compile test-linearize example test-unssa test-dissect +PROGRAMS=test-lexing test-parsing obfuscate check compile graph test-linearize example test-unssa test-dissect LIB_H= token.h parse.h lib.h symbol.h scope.h expression.h target.h \ linearize.h bitmap.h ident-list.h compat.h flow.h allocate.h \ @@ -77,6 +77,9 @@ obfuscate: obfuscate.o $(LIBS) check: check.o $(LIBS) $(CC) $(LDFLAGS) -o $@ $< $(LIBS) +graph: graph.o $(LIBS) + $(CC) $(LDFLAGS) -o $@ $< $(LIBS) + example: example.o $(LIBS) $(CC) $(LDFLAGS) -o $@ $< $(LIBS) @@ -123,6 +126,7 @@ obfuscate.o: $(LIB_H) example.o: $(LIB_H) storage.o: $(LIB_H) storage.h dissect.o: $(LIB_H) dissect.h +graph.o: $(LIB_H) compat-linux.o: compat/strtold.c compat/mmap-blob.c \ $(LIB_H) |