aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2007-09-15 09:37:58 -0700
committerJosh Triplett <josh@freedesktop.org>2007-09-15 09:44:02 -0700
commit401bd51e449403e1bc45fce692f69af0fe28bb2d (patch)
treea179b130a24e28376a001c29cf78ba900f1e49b0 /Makefile
parentAdd test-suite annotations to noderef.c (diff)
downloadsparse-401bd51e449403e1bc45fce692f69af0fe28bb2d.tar.gz
sparse-401bd51e449403e1bc45fce692f69af0fe28bb2d.tar.bz2
sparse-401bd51e449403e1bc45fce692f69af0fe28bb2d.zip
Makefile: Use ?= to allow overriding OS or AR on the Make command line
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ea4a4d3..5101473 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,12 @@
VERSION=0.3
-OS=linux
+OS ?= linux
CC ?= gcc
CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
CFLAGS += -Wall -Wwrite-strings
LDFLAGS ?= -g
-AR=ar
+AR ?= ar
HAVE_LIBXML=$(shell pkg-config --exists libxml-2.0 && echo 'yes')