aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Torvalds <torvalds@home.transmeta.com>2003-04-07 16:23:10 -0700
committerLinus Torvalds <torvalds@ppc970.osdl.org>2005-04-07 21:00:20 -0700
commitb23fc8af8e708eaf90ae8b55dad1f5e991360edc (patch)
tree6a645df662ad48e4166f776051cb8d84abd130be /Makefile
parentMark inline functions as accessed when they get called. We should (diff)
downloadsparse-b23fc8af8e708eaf90ae8b55dad1f5e991360edc.tar.gz
sparse-b23fc8af8e708eaf90ae8b55dad1f5e991360edc.tar.bz2
sparse-b23fc8af8e708eaf90ae8b55dad1f5e991360edc.zip
Add "check" program that just evaluates the tree and does nothing
else. This is useful to get warnings from the parser and type evaluator.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1f3a569..8205e97 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
CC=gcc
CFLAGS=-g -Wall
-PROGRAMS=test-lexing test-parsing obfuscate
+PROGRAMS=test-lexing test-parsing obfuscate check
HEADERS=token.h parse.h lib.h symbol.h scope.h expression.h target.h
@@ -19,6 +19,9 @@ test-parsing: test-parsing.o $(COMMON)
obfuscate: obfuscate.o $(COMMON)
gcc -o $@ $< $(COMMON)
+check: check.o $(COMMON)
+ gcc -o $@ $< $(COMMON)
+
evaluate.o: $(HEADERS)
expression.o: $(HEADERS)
lib.o: $(HEADERS)