summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/dmd/dmd-2.064.2.ebuild')
-rw-r--r--dev-lang/dmd/dmd-2.064.2.ebuild32
1 files changed, 25 insertions, 7 deletions
diff --git a/dev-lang/dmd/dmd-2.064.2.ebuild b/dev-lang/dmd/dmd-2.064.2.ebuild
index 7692d1f19..9341a6d55 100644
--- a/dev-lang/dmd/dmd-2.064.2.ebuild
+++ b/dev-lang/dmd/dmd-2.064.2.ebuild
@@ -19,21 +19,39 @@ IUSE="multilib doc examples tools"
LICENSE="DMD"
RESTRICT="mirror"
-DEPEND="app-arch/unzip
- sys-apps/findutils
- virtual/awk"
-RDEPEND="!dev-lang/dmd-bin"
+CURL_DEPEND="
+ !amd64? ( net-misc/curl )
+ amd64? (
+ abi_x86_64? ( net-misc/curl )
+ abi_x86_32? ( app-emulation/emul-linux-x86-baselibs )
+ )"
+
+DEPEND="
+ ${CURL_DEPEND}
+ app-arch/unzip
+ "
+RDEPEND="
+ ${CURL_DEPEND}
+ !dev-lang/dmd-bin
+ "
S="${WORKDIR}/dmd2"
+rdos2unix() {
+ edos2unix $(find . -name '*'.$1 -type f) || die "Failed to convert line-endings of all .$1 files"
+}
+
src_prepare() {
# Remove precompiled binaries and non-essential files.
rm -r README.TXT windows osx linux/lib{32,64} linux/bin{32,64}/{README.TXT,dmd,dmd.conf} \
|| die "Failed to remove included binaries."
# convert line-endings of file-types that start as cr-lf and are patched or installed later on
- find . -name "*.txt" -o -name "*.html" -o -name "*.d" -o -name "*.di" -o -name "*.ddoc" -type f -exec edos2unix {} \; \
- || die "Failed to convert DOS line-endings to Unix."
+ rdos2unix txt
+ rdos2unix html
+ rdos2unix d
+ rdos2unix di
+ rdos2unix ddoc
# patch: copy VERSION file into dmd directory
cp src/VERSION src/dmd/VERSION \
@@ -58,7 +76,7 @@ dmd_foreach_abi() {
src_compile() {
# A native build of dmd is used to compile the runtimes for both x86 and amd64
- # We cannot use multilib-minimal yet, as we have to be sure dmd for amd64
+ # We cannot use multilib-minimal yet, as we have to be sure dmd for amd64
# always gets build first.
einfo 'Building dmd ...'
emake -C src/dmd -f posix.mak TARGET_CPU=X86 RELEASE=1