summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-02-12 11:15:45 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-12 11:15:49 +0100
commitc20bbb8aac0d34b3f53012668b73d87704d7fcd7 (patch)
tree742fe3e9db69d855bde66e654b36e7b31aa3d31d
parenttexlive-common.eclass: add --ignore-errors to etexmf-update and efmtutil-sys (diff)
downloadtex-overlay-c20bbb8aac0d34b3f53012668b73d87704d7fcd7.tar.gz
tex-overlay-c20bbb8aac0d34b3f53012668b73d87704d7fcd7.tar.bz2
tex-overlay-c20bbb8aac0d34b3f53012668b73d87704d7fcd7.zip
app-text/texlive-core: invoke efmtutil-sys from the eclass and use --ignore-errors
texlive-core always invoked texmf-update and fmtutil-sys ignore its exit status, but with the recent eclass change etexmf-update became sensitive to its exit status. And since we now invoke efmtutil-sys, instead of invoking fmtutil-sys directly, we have to use --ignore-errors to restore the original behavior of the ebuild. Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-text/texlive-core/texlive-core-2023.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-text/texlive-core/texlive-core-2023.ebuild b/app-text/texlive-core/texlive-core-2023.ebuild
index f09dc64..07d1909 100644
--- a/app-text/texlive-core/texlive-core-2023.ebuild
+++ b/app-text/texlive-core/texlive-core-2023.ebuild
@@ -740,14 +740,16 @@ src_install() {
}
pkg_postinst() {
- etexmf-update
-
- # Note that the fmtutil-sys call has no "|| die" attached to it. We
- # are here in pkg_postinst where invoking die is not sensible.
- # TODO: Research the rationale of calling fmtutil-sys here and the
- # reasons why it fails.
- einfo "Regenerating TeX formats"
- fmtutil-sys --all &> /dev/null
+ # Note that the etexmf-update and efmtutil-sys use nonfatal. We are
+ # pkg_postinst, so invoking die will merely print an error message
+ # but not abort the installation as it already happened. However,
+ # unlike the texlive modules, we observed fmtutil-sys failures in
+ # texlive-core.
+
+ # TODO: Research the rationale of calling etexmf-update and
+ # eftmutil-sys here and the reasons why it fails.
+ etexmf-update --ignore-errors
+ efmtutil-sys --ignore-errors
elog
elog "If you have configuration files in ${EPREFIX}/etc/texmf to merge,"