summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/extract-xiso/extract-xiso-2.7.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-cdr/extract-xiso/extract-xiso-2.7.1.ebuild b/app-cdr/extract-xiso/extract-xiso-2.7.1.ebuild
index c89c16d1ea41..f4e6324db818 100644
--- a/app-cdr/extract-xiso/extract-xiso-2.7.1.ebuild
+++ b/app-cdr/extract-xiso/extract-xiso-2.7.1.ebuild
@@ -1,25 +1,28 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_PV=${PV/_beta/b}
DESCRIPTION="Tool for extracting and creating optimised Xbox ISO images"
HOMEPAGE="https://sourceforge.net/projects/extract-xiso"
SRC_URI="mirror://sourceforge/extract-xiso/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="BSD-4"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.1-headers.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.7.1-headers.patch
+ default
+
sed -i \
-e 's:__LINUX__:__linux__:' \
*.[ch] */*.[ch] || die