summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-02 13:06:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-02 13:06:38 +0000
commit244d00a9ac746b77ad74d02376626fda171da5f4 (patch)
tree28fbd789edb4ca3821b156cbb8a91c155952beb7 /app-accessibility/accerciser
parentAdd ~arm/~ia64/~sh/~sparc wrt #264840 (diff)
downloadhistorical-244d00a9ac746b77ad74d02376626fda171da5f4.tar.gz
historical-244d00a9ac746b77ad74d02376626fda171da5f4.tar.bz2
historical-244d00a9ac746b77ad74d02376626fda171da5f4.zip
New ebuild for GNOME 2.26.
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'app-accessibility/accerciser')
-rw-r--r--app-accessibility/accerciser/ChangeLog10
-rw-r--r--app-accessibility/accerciser/Manifest14
-rw-r--r--app-accessibility/accerciser/accerciser-1.6.1.ebuild60
-rw-r--r--app-accessibility/accerciser/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/ChangeLog b/app-accessibility/accerciser/ChangeLog
new file mode 100644
index 000000000000..ad0af0a81b06
--- /dev/null
+++ b/app-accessibility/accerciser/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-accessibility/accerciser
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.1 2009/05/02 13:06:38 eva Exp $
+
+*accerciser-1.6.1 (02 May 2009)
+
+ 02 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +accerciser-1.6.1.ebuild, +metadata.xml:
+ New ebuild for GNOME 2.26.
+
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
new file mode 100644
index 000000000000..e706a26b3838
--- /dev/null
+++ b/app-accessibility/accerciser/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST accerciser-1.6.1.tar.bz2 1345128 RMD160 99970747ea70569bccd28e3c508f500667377b99 SHA1 16dc8523e533b046b53bc37ff7be1b05b752e183 SHA256 22c362a04025c876d5b454b7016edc888b737098d93b23e18f9f7cd59ba7ecf0
+EBUILD accerciser-1.6.1.ebuild 1440 RMD160 8f4f403e65af42c8a29b87f5ba6f91576a4034e7 SHA1 3e372eb856d7f16b5856ec02d600460c3d2d6f8a SHA256 1f7ff27985e064ee9162866c24fc4c74c43ec89dcecad752232022313434f7fe
+MISC ChangeLog 386 RMD160 4111aeb57b935894eb53f6dbb138b932bf835016 SHA1 616933613ef7a04cbc204601d97d756911084a82 SHA256 95d66d9b737955227d76f09d8ef2c6ab707be15ac8348aa0a189b46a2ea476d5
+MISC metadata.xml 650 RMD160 26c97af9afcecd5183b8adee388548ec3b1d9dfa SHA1 3987a58ce7c0dde5abdae7f56177c8a674c507c2 SHA256 f43768c69093086ebb1969ef7c4fbd6babc7a57e246d76dadcf5c750813a7008
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkn8RW4ACgkQ1fmVwcYIWAaMyACfWsb0G+kgq+yNVHGYgHzJwiCN
+cw0An05tw436LS4wtXBGMm23ykjHVJAh
+=SC2q
+-----END PGP SIGNATURE-----
diff --git a/app-accessibility/accerciser/accerciser-1.6.1.ebuild b/app-accessibility/accerciser/accerciser-1.6.1.ebuild
new file mode 100644
index 000000000000..ed5328bad0cb
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-1.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-1.6.1.ebuild,v 1.1 2009/05/02 13:06:38 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 python
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="AUTHORS COPYING ChangeLog NEWS README"
+
+RDEPEND=">=dev-lang/python-2.4
+ dev-python/ipython
+ dev-python/pygtk
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/libgnome-python
+ dev-python/libwnck-python
+ dev-python/gtksourceview-python
+ dev-python/gconf-python
+ dev-python/librsvg-python
+ >=gnome-extra/at-spi-1.7
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.12"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --without-pyreqs"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize "$(python_get_sitedir)/accerciser"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/accerciser
+}
diff --git a/app-accessibility/accerciser/metadata.xml b/app-accessibility/accerciser/metadata.xml
new file mode 100644
index 000000000000..bd9b37909490
--- /dev/null
+++ b/app-accessibility/accerciser/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-accessibility</herd>
+<longdescription lang="en">
+Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.
+
+In essence, Accerciser is a next generation at-poke tool.
+</longdescription>
+</pkgmetadata>
+