summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 23:56:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 23:56:50 +0000
commitcb12b723820639f024686025261c12a793a46979 (patch)
tree54970371d7741c39c42f48cb0eb1e1b5b8459878 /app-arch/star
parentstable on amd64 (diff)
downloadhistorical-cb12b723820639f024686025261c12a793a46979.tar.gz
historical-cb12b723820639f024686025261c12a793a46979.tar.bz2
historical-cb12b723820639f024686025261c12a793a46979.zip
touch the libc
Diffstat (limited to 'app-arch/star')
-rw-r--r--app-arch/star/star-1.4.3.ebuild10
-rw-r--r--app-arch/star/star-1.5_alpha14.ebuild11
2 files changed, 13 insertions, 8 deletions
diff --git a/app-arch/star/star-1.4.3.ebuild b/app-arch/star/star-1.4.3.ebuild
index 2a8c025e0542..d9da800e5af7 100644
--- a/app-arch/star/star-1.4.3.ebuild
+++ b/app-arch/star/star-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.4.3.ebuild,v 1.5 2004/06/24 21:36:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.4.3.ebuild,v 1.6 2004/06/25 23:55:18 vapier Exp $
DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html"
@@ -14,15 +14,17 @@ SLOT="0"
KEYWORDS="x86 ppc ~sparc ~mips amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S=${WORKDIR}/${P/_alpha[0-9][0-9]}
src_unpack() {
unpack ${A}
cd ${S}/DEFAULTS
- cp Defaults.linux Defaults.linux.orig
- sed -e 's:/opt/schily:/usr:g' -e 's:bin:root:g' Defaults.linux.orig > Defaults.linux
+ sed -i \
+ -e 's:/opt/schily:/usr:g' \
+ -e 's:bin:root:g' \
+ Defaults.linux
}
src_compile() {
diff --git a/app-arch/star/star-1.5_alpha14.ebuild b/app-arch/star/star-1.5_alpha14.ebuild
index 17be19b2b54b..226bfbe4a08c 100644
--- a/app-arch/star/star-1.5_alpha14.ebuild
+++ b/app-arch/star/star-1.5_alpha14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.5_alpha14.ebuild,v 1.7 2004/06/24 21:36:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.5_alpha14.ebuild,v 1.8 2004/06/25 23:55:18 vapier Exp $
S=${WORKDIR}/${P/_alpha[0-9][0-9]}
@@ -16,13 +16,16 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc ~mips alpha hppa amd64 ia64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}/DEFAULTS
- sed -e 's:/opt/schily:/usr:g' -e 's:bin:root:g' -i Defaults.linux
- sed -e 's:/usr/src/linux/include:/usr/include:' -i Defaults.linux
+ sed -i \
+ -e 's:/opt/schily:/usr:g' \
+ -e 's:bin:root:g' \
+ -e 's:/usr/src/linux/include:/usr/include:' \
+ Defaults.linux
if [ "${ARCH}" = "amd64" ]
then