summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-16 21:15:37 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-16 21:15:37 +0000
commit13614b5724f84dcc3936fe0a8d225334994c3ae7 (patch)
tree7f8513449536e9fd66bd42e73911d25b5d727e9f /app-editors/ghex
parentadded patch from Karl Haines fixing installation path (diff)
downloadhistorical-13614b5724f84dcc3936fe0a8d225334994c3ae7.tar.gz
historical-13614b5724f84dcc3936fe0a8d225334994c3ae7.tar.bz2
historical-13614b5724f84dcc3936fe0a8d225334994c3ae7.zip
added ebuild from Tod
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/files/digest-ghex-1.2.11
-rw-r--r--app-editors/ghex/ghex-1.2.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/ghex/files/digest-ghex-1.2.1 b/app-editors/ghex/files/digest-ghex-1.2.1
new file mode 100644
index 000000000000..19bdf30d564f
--- /dev/null
+++ b/app-editors/ghex/files/digest-ghex-1.2.1
@@ -0,0 +1 @@
+MD5 2ec336790ca1e5e475152520cead78e5 ghex-1.2.1.tar.gz 675840
diff --git a/app-editors/ghex/ghex-1.2.1.ebuild b/app-editors/ghex/ghex-1.2.1.ebuild
new file mode 100644
index 000000000000..2e46f3aebcdb
--- /dev/null
+++ b/app-editors/ghex/ghex-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-1.2.1.ebuild,v 1.1 2002/01/16 21:15:37 hallski Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Gnome Hexadecimal editor"
+
+SRC_URI="http://pluton.ijs.si/~jaka/${P}.tar.gz"
+
+HOMEPAGE="http://pluton.ijs.si/~jaka/gnome.html"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=gnome-base/gnome-libs-1.4.1.2-r3
+ >=gnome-base/ORBit-0.5.12-r1
+ >=gnome-base/gnome-print-0.34
+ >=app-text/scrollkeeper-0.2"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf=""
+
+ use nls || myconf="$myconf --disable-nls" #default enabled
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ GNOME_DATA_DIR=${D}/usr/share \
+ install || die "Installation Failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING COPYING-DOCS ChangeLog INSTALL \
+ NEWS README
+}