summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-04 16:18:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-04 16:18:53 +0000
commitb86d4e146deba68ae9834aba2a648d5078c278e2 (patch)
tree8c2ad49ba8883ca0dc777366b8e96935016f86ce /app-emulation/softgun
parentVersion bump (diff)
downloadhistorical-b86d4e146deba68ae9834aba2a648d5078c278e2.tar.gz
historical-b86d4e146deba68ae9834aba2a648d5078c278e2.tar.bz2
historical-b86d4e146deba68ae9834aba2a648d5078c278e2.zip
Version bump.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/ChangeLog7
-rw-r--r--app-emulation/softgun/Manifest4
-rw-r--r--app-emulation/softgun/files/digest-softgun-0.081
-rw-r--r--app-emulation/softgun/softgun-0.08.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/app-emulation/softgun/ChangeLog b/app-emulation/softgun/ChangeLog
index b3cfccb009ed..122cae9b919a 100644
--- a/app-emulation/softgun/ChangeLog
+++ b/app-emulation/softgun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/softgun
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.2 2005/01/01 14:16:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.3 2005/03/04 16:18:53 vapier Exp $
+
+*softgun-0.08 (04 Mar 2005)
+
+ 04 Mar 2005; Mike Frysinger <vapier@gentoo.org> +softgun-0.08.ebuild:
+ Version bump.
*softgun-0.07 (05 Dec 2004)
diff --git a/app-emulation/softgun/Manifest b/app-emulation/softgun/Manifest
index aab57e4ed80b..e909188802a6 100644
--- a/app-emulation/softgun/Manifest
+++ b/app-emulation/softgun/Manifest
@@ -1,4 +1,6 @@
-MD5 199db45ca4d070595cb064b1f62117c3 ChangeLog 363
+MD5 91158797850a40e306ccc5bc9ca6df2c ChangeLog 477
MD5 48834ccc5ffa5b7734f8cac702fcd38a metadata.xml 156
+MD5 97eb29afd28ce41b1a0d3e3cbd28b5f6 softgun-0.08.ebuild 993
MD5 650891749c4602c2c4836d4200d97025 softgun-0.07.ebuild 990
MD5 ad6c326f2a31bc17f529c4d0fa6296a1 files/digest-softgun-0.07 61
+MD5 d6b2da592b3ea5021781d5d47bb6b693 files/digest-softgun-0.08 61
diff --git a/app-emulation/softgun/files/digest-softgun-0.08 b/app-emulation/softgun/files/digest-softgun-0.08
new file mode 100644
index 000000000000..05ec5c373622
--- /dev/null
+++ b/app-emulation/softgun/files/digest-softgun-0.08
@@ -0,0 +1 @@
+MD5 ef9f04587ea3a81ceabd2867be6bbdd7 softgun-0.08.tgz 153086
diff --git a/app-emulation/softgun/softgun-0.08.ebuild b/app-emulation/softgun/softgun-0.08.ebuild
new file mode 100644
index 000000000000..f36ff2c00370
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.08.ebuild,v 1.1 2005/03/04 16:18:53 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc README defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}