summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2007-05-05 10:15:32 +0000
committerAlistair Bush <ali_bush@gentoo.org>2007-05-05 10:15:32 +0000
commit4e9cfa48eefb2cf392e13ff45a9842f78f7ab800 (patch)
tree92c296faca1d1e3df91c93f9c061196e313ec1c6 /app-misc/jbidwatcher
parentVersion bump (bug #176174): minor cleanup, added NEED_PYTHON, added examples ... (diff)
downloadhistorical-4e9cfa48eefb2cf392e13ff45a9842f78f7ab800.tar.gz
historical-4e9cfa48eefb2cf392e13ff45a9842f78f7ab800.tar.bz2
historical-4e9cfa48eefb2cf392e13ff45a9842f78f7ab800.zip
Version Bump
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'app-misc/jbidwatcher')
-rw-r--r--app-misc/jbidwatcher/ChangeLog8
-rw-r--r--app-misc/jbidwatcher/files/digest-jbidwatcher-1.0.13
-rw-r--r--app-misc/jbidwatcher/jbidwatcher-1.0.1.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/app-misc/jbidwatcher/ChangeLog b/app-misc/jbidwatcher/ChangeLog
index 851c49f6864b..2aa8fb561540 100644
--- a/app-misc/jbidwatcher/ChangeLog
+++ b/app-misc/jbidwatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/jbidwatcher
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/ChangeLog,v 1.28 2007/02/21 22:34:18 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/ChangeLog,v 1.29 2007/05/05 10:15:32 ali_bush Exp $
+
+*jbidwatcher-1.0.1 (05 May 2007)
+
+ 05 May 2007; Alistair John Bush <ali_bush@gentoo.org>
+ +jbidwatcher-1.0.1.ebuild:
+ Version bump
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-misc/jbidwatcher/files/digest-jbidwatcher-1.0.1 b/app-misc/jbidwatcher/files/digest-jbidwatcher-1.0.1
new file mode 100644
index 000000000000..c16e146415ac
--- /dev/null
+++ b/app-misc/jbidwatcher/files/digest-jbidwatcher-1.0.1
@@ -0,0 +1,3 @@
+MD5 2f01b5940757a159751b52f454b496c4 jbidwatcher-1.0.1.tar.gz 639698
+RMD160 b4f2da6d845e49c4f43ed4ce5b0152586f6de593 jbidwatcher-1.0.1.tar.gz 639698
+SHA256 2a08b718c9e3ab8db46e85c2e67e69600f7626c023ce82d476924dd070bbd687 jbidwatcher-1.0.1.tar.gz 639698
diff --git a/app-misc/jbidwatcher/jbidwatcher-1.0.1.ebuild b/app-misc/jbidwatcher/jbidwatcher-1.0.1.ebuild
new file mode 100644
index 000000000000..98438a0a7d15
--- /dev/null
+++ b/app-misc/jbidwatcher/jbidwatcher-1.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-1.0.1.ebuild,v 1.1 2007/05/05 10:15:32 ali_bush Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PV=${PV/_/} # get rid of underscore between version and pre
+MY_PN="JBidWatcher"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Java-based eBay bidding, sniping and tracking tool"
+HOMEPAGE="http://www.jbidwatcher.com/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix bad build.xml (used to be the sed)
+ epatch "${FILESDIR}/${PN}-1.0-build_xml.patch"
+ epatch "${FILESDIR}/${PN}-0.9.8-javadoc.patch"
+ # jdictrayapi and tritonus are here
+ #rm -fr org
+ # apple stuff and pat stuff
+ #rm -rf com
+ #rm -fr javazoom
+}
+
+src_compile() {
+ eant jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar ${MY_PN}-${MY_PV}.jar ${PN}.jar
+
+ use doc && java-pkg_dohtml -r docs/api
+
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ newicon jbidwatch64.jpg ${PN}.jpg
+ make_desktop_entry ${PN} ${MY_PN}
+}