summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-04 10:47:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-04 10:47:00 +0000
commit0821250f93631bd9e09f7483300b4a111c93fa06 (patch)
tree51bd3d506141169e7253ed9346f4498ea7519d72 /app-office
parentRemove inactive mainainer (diff)
downloadhistorical-0821250f93631bd9e09f7483300b4a111c93fa06.tar.gz
historical-0821250f93631bd9e09f7483300b4a111c93fa06.tar.bz2
historical-0821250f93631bd9e09f7483300b4a111c93fa06.zip
Add workaround for the old gcc boost issue as I dont want to patch each and individual boost version we have. On live ebuild and 3.7 (4.0) require 4.6 gcc.
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0x8EEE3BE8
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog8
-rw-r--r--app-office/libreoffice/libreoffice-3.6.3.2.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-3.6.9999.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild6
4 files changed, 24 insertions, 6 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index c21ef2fd002d..8d9e9fe67169 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.384 2012/11/02 12:22:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.385 2012/11/04 10:47:00 scarabeus Exp $
+
+ 04 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-3.6.3.2.ebuild,
+ libreoffice-3.6.9999.ebuild, libreoffice-9999-r2.ebuild:
+ Add workaround for the old gcc boost issue as I dont want to patch each and
+ individual boost version we have. On live ebuild and 3.7 (4.0) require 4.6
+ gcc.
*libreoffice-3.6.3.2 (02 Nov 2012)
*libreoffice-3.5.7.2 (02 Nov 2012)
diff --git a/app-office/libreoffice/libreoffice-3.6.3.2.ebuild b/app-office/libreoffice/libreoffice-3.6.3.2.ebuild
index a2243f7e1e48..aadda3055e79 100644
--- a/app-office/libreoffice/libreoffice-3.6.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.6.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.3.2.ebuild,v 1.1 2012/11/02 12:22:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.3.2.ebuild,v 1.2 2012/11/04 10:47:00 scarabeus Exp $
EAPI=4
@@ -351,6 +351,12 @@ src_configure() {
local ext_opts
local jbs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
+ # Workaround the boost header include issue for older gccs
+ if [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]]; then
+ append-cppflags -DBOOST_NO_0X_HDR_TYPEINDEX
+ append-cppflags -DBOOST_NO_CXX11_HDR_TYPEINDEX
+ fi
+
# recheck that there is some value in jobs
[[ -z ${jbs} ]] && jbs="1"
diff --git a/app-office/libreoffice/libreoffice-3.6.9999.ebuild b/app-office/libreoffice/libreoffice-3.6.9999.ebuild
index ec99c1946ab3..7e8659bfd464 100644
--- a/app-office/libreoffice/libreoffice-3.6.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-3.6.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.9999.ebuild,v 1.29 2012/09/24 08:26:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.9999.ebuild,v 1.30 2012/11/04 10:47:00 scarabeus Exp $
EAPI=4
@@ -350,6 +350,12 @@ src_configure() {
local ext_opts
local jbs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
+ # Workaround the boost header include issue for older gccs
+ if [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]]; then
+ append-cppflags -DBOOST_NO_0X_HDR_TYPEINDEX
+ append-cppflags -DBOOST_NO_CXX11_HDR_TYPEINDEX
+ fi
+
# recheck that there is some value in jobs
[[ -z ${jbs} ]] && jbs="1"
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 27741d7474ad..bef03e2558a7 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.122 2012/10/30 21:00:29 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.123 2012/11/04 10:47:00 scarabeus Exp $
EAPI=4
@@ -250,9 +250,9 @@ pkg_pretend() {
check-reqs_pkg_pretend
if [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 5 ]] ) \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
; then
- eerror "Compilation with gcc older than 4.5 is not supported"
+ eerror "Compilation with gcc older than 4.6 is not supported"
die "Too old gcc found."
fi
fi