summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-12-21 16:26:37 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-12-21 16:26:37 +0000
commit89f3204bd1a69612f753d7cc714752f314fbe3c2 (patch)
treea31391081cc81792b065d95935e53297e18545fc /app-office
parentAdded ~ppc64; bug #101051 (diff)
downloadhistorical-89f3204bd1a69612f753d7cc714752f314fbe3c2.tar.gz
historical-89f3204bd1a69612f753d7cc714752f314fbe3c2.tar.bz2
historical-89f3204bd1a69612f753d7cc714752f314fbe3c2.zip
New upstream release
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/ChangeLog9
-rw-r--r--app-office/openoffice-bin/Manifest5
-rwxr-xr-xapp-office/openoffice-bin/files/2.0.1/ooo-wrapper2119
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-2.0.160
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.1.ebuild196
5 files changed, 387 insertions, 2 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 490021542132..4f37d73b1a8c 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.114 2005/12/12 09:08:17 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.115 2005/12/21 16:26:37 suka Exp $
+
+*openoffice-bin-2.0.1 (21 Dec 2005)
+
+ 21 Dec 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/2.0.1/ooo-wrapper2, +openoffice-bin-2.0.1.ebuild:
+ New upstream release, no big new features but lots of bugfixes, also this
+ adds a few more translations
12 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
openoffice-bin-2.0.0.ebuild:
diff --git a/app-office/openoffice-bin/Manifest b/app-office/openoffice-bin/Manifest
index 7241455c3078..b729c5e795ae 100644
--- a/app-office/openoffice-bin/Manifest
+++ b/app-office/openoffice-bin/Manifest
@@ -1,8 +1,11 @@
-MD5 4d31252a9cab2e6e2a46470f3626b5c8 ChangeLog 20217
+MD5 7fa070fa2f95f5dd228212424b669f9c ChangeLog 20469
MD5 475dbfca78a66962143b39d3aac7915a files/1.1.5/ooffice-wrapper-1.3 6659
MD5 2919847c6afebe7fd157c48e78fb5770 files/2.0.0/ooo-wrapper2 3703
+MD5 2919847c6afebe7fd157c48e78fb5770 files/2.0.1/ooo-wrapper2 3703
MD5 5828bbd9e0139dae2ff43c23a65a844b files/digest-openoffice-bin-1.1.5 82
MD5 72776dcacfb2853f6056793f531d7986 files/digest-openoffice-bin-2.0.0 4709
+MD5 27636f8cdec7c8d98e491ff4f4d12c62 files/digest-openoffice-bin-2.0.1 5639
MD5 7134ec08f56019fc5db7f3e84acea4df metadata.xml 460
MD5 754b2a399f6c90c5a6f17d2efc30131d openoffice-bin-1.1.5.ebuild 4718
MD5 f344222ab0436a614899026976bb02d2 openoffice-bin-2.0.0.ebuild 6960
+MD5 d2810aa2adaa6fd9eff3e93564dde48d openoffice-bin-2.0.1.ebuild 7578
diff --git a/app-office/openoffice-bin/files/2.0.1/ooo-wrapper2 b/app-office/openoffice-bin/files/2.0.1/ooo-wrapper2
new file mode 100755
index 000000000000..e67fd85a5843
--- /dev/null
+++ b/app-office/openoffice-bin/files/2.0.1/ooo-wrapper2
@@ -0,0 +1,119 @@
+#!/usr/bin/perl -w
+#*****************************************************************************
+#
+# ooffice - Wrapper script for OpenOffice.org
+#
+# Based on the Mandrake work.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2, as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+#*****************************************************************************
+
+use strict;
+use IO::Handle;
+use Fcntl ':flock';
+
+my $Debug = $ENV{OOO_DEBUG};
+
+# Define the vendor of this particular OOo package
+my $VendorName = 'Gentoo';
+# Define system installation directory
+# Autoconf totally sucks for @libdir@ type substitution
+my $SystemInstallDir = 'INSTDIR';
+# Suffix for parallel installable versioning
+my $BinSuffix = '2';
+# ooo-build version
+my $OOO_BUILDVERSION = 'PV';
+
+#=============================================================================
+# Main
+#=============================================================================
+
+# Parse command line arguments
+my @ooo_argv;
+my $session_quickstart;
+my $widgets_set;
+while ($ARGV[0]) {
+ $_ = shift;
+ if (m/^--session-quickstart/) {
+ $session_quickstart = 1;
+ } elsif (m/^--widgets-set/) {
+ $widgets_set = shift;
+ (defined $widgets_set) || die "Error: The option --widgets-set requires a value\n" .
+ "For example: --widgets-set gtk\n";
+ } elsif (m/^--version/) {
+ print "This is OpenOffice.org $OOO_BUILDVERSION\n";
+ exit 0;
+ } else {
+ push @ooo_argv, $_;
+ }
+}
+
+if (!@ooo_argv) {
+ my $arg;
+ if ($0 =~ m/\/oo(calc|draw|impress|math|web|writer|base)$BinSuffix$/) {
+ $arg = "-$1";
+ } elsif ($0 =~ m/\/oofromtemplate$BinSuffix$/) {
+ $arg = "slot:5500";
+ }
+
+ if ($arg) {
+ push @ooo_argv, "$arg";
+ $Debug && print "Append arg: $arg\n";
+ }
+} else {
+ $Debug && print "Ignoring type - since have filenames\n";
+}
+
+if (defined $widgets_set) {
+ $ENV{SAL_USE_VCLPLUGIN} = $widgets_set;
+}
+
+# overcome ghastly up-stream evilness
+$ENV{SAL_NOEXPANDFPICKER}='TRUE';
+
+if ($session_quickstart) {
+ $Debug && print "Execute quickstarter\n";
+ push @ooo_argv, '-quickstart';
+}
+
+# FIXME: the following two fixes should be done by OOo itself
+# create the user config directory with safe rights 700 if it we find
+# the right path and the directory does not exist
+if (open BOOTSTRAPRC, "$SystemInstallDir/program/bootstraprc") {
+ while (my $line = <BOOTSTRAPRC>) {
+ chomp $line;
+ if (($line =~ m/^\s*UserInstallation\s*=\s*([^\s]*)\s*$/) && ($1)) {
+ my $userConfDir=$1;
+ $userConfDir =~ s|\$SYSUSERCONFIG|$ENV{HOME}|;
+ $userConfDir =~ s|file://||;
+ mkdir ($userConfDir,0700) unless (-d $userConfDir);
+ last;
+ }
+ }
+ close BOOTSTRAPRC;
+}
+# touch ~/.recently-used with safe rights 700 if it does not exist
+if (! -f "$ENV{HOME}/.recently-used") {
+ open (RECENTLY_USED, ">$ENV{HOME}/.recently-used") &&
+ close RECENTLY_USED &&
+ chmod 0600, "$ENV{HOME}/.recently-used";
+}
+
+if (!(-f '/proc/version')) {
+ print STDERR "\n\n --- Warning - OO.o will not work without a mounted /proc filesystem --- \n\n\n";
+}
+
+# And here we go.
+exec "$SystemInstallDir/program/soffice", @ooo_argv
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.1 b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.1
new file mode 100644
index 000000000000..439abcbc43a3
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.1
@@ -0,0 +1,60 @@
+MD5 e0d123e5f316bef78bfdf5a008837577 OOo_2.0.1_LinuxIntel_install.tar.gz 109237237
+MD5 152c35114f57cb072fdf6274f8975cf5 OOo_2.0.1rc5_051215_LinuxIntel_langpack_af.tar.gz 26898291
+MD5 7133679f4c0010f12b9a430b9ca8fd98 OOo_2.0.1rc5_051215_LinuxIntel_langpack_be-BY.tar.gz 27045217
+MD5 e0e3e1ba9fbcaa2032f41978144d1917 OOo_2.0.1rc5_051215_LinuxIntel_langpack_bg.tar.gz 28125491
+MD5 a2d8083ac411aaa0fb0779f2c66767c4 OOo_2.0.1rc5_051215_LinuxIntel_langpack_bs.tar.gz 26911879
+MD5 69d292a587f1f2c1adb1db23cb5380ff OOo_2.0.1rc5_051215_LinuxIntel_langpack_ca.tar.gz 26901519
+MD5 5545306de96a28fb1f96af5f1dd65987 OOo_2.0.1rc5_051215_LinuxIntel_langpack_cs.tar.gz 28137385
+MD5 cec8338e184e21c892c45f51a3ddd848 OOo_2.0.1rc5_051215_LinuxIntel_langpack_cy.tar.gz 26845111
+MD5 440a5be08f55c0f344d7c92ea90f36fc OOo_2.0.1rc5_051215_LinuxIntel_langpack_da.tar.gz 27989111
+MD5 23c4402967beb6e6857efb6c238cf084 OOo_2.0.1rc5_051215_LinuxIntel_langpack_de.tar.gz 29925895
+MD5 5dbab9fbc56c36450854d4bb1f99c35d OOo_2.0.1rc5_051215_LinuxIntel_langpack_el.tar.gz 27010457
+MD5 ffaa6aaf756a2bfd4c954196045a5e8a OOo_2.0.1rc5_051215_LinuxIntel_langpack_en-GB.tar.gz 25524967
+MD5 fcb25a4df718e73fc7d4dfde71f408f9 OOo_2.0.1rc5_051215_LinuxIntel_langpack_en-ZA.tar.gz 26895694
+MD5 586b2f311ebc5de8313bfd0f91b25429 OOo_2.0.1rc5_051215_LinuxIntel_langpack_es.tar.gz 28544685
+MD5 0114c76764006bc515c35bc3f89e163c OOo_2.0.1rc5_051215_LinuxIntel_langpack_et.tar.gz 28328805
+MD5 9bff8b382de42888e6285af263dedd9b OOo_2.0.1rc5_051215_LinuxIntel_langpack_fi.tar.gz 26920945
+MD5 e3579db0856fb69ae47f7ca8da06cdbe OOo_2.0.1rc5_051215_LinuxIntel_langpack_fr.tar.gz 28937603
+MD5 4f216ce12069e3f1691ff47607fe0497 OOo_2.0.1rc5_051215_LinuxIntel_langpack_gu-IN.tar.gz 27008419
+MD5 40613a1695c550c55359f00bca0d4fd5 OOo_2.0.1rc5_051215_LinuxIntel_langpack_hi-IN.tar.gz 27169875
+MD5 02d0fce9730789c892b09097f7f41681 OOo_2.0.1rc5_051215_LinuxIntel_langpack_hr.tar.gz 27549101
+MD5 266f09b8131241ffba614881bba1c79e OOo_2.0.1rc5_051215_LinuxIntel_langpack_hu.tar.gz 29810288
+MD5 624a165badfbfd69f8ef0cbc73230ff4 OOo_2.0.1rc5_051215_LinuxIntel_langpack_it.tar.gz 28450321
+MD5 98538fb7c843a0f748797236577e8cc1 OOo_2.0.1rc5_051215_LinuxIntel_langpack_ja.tar.gz 30048446
+MD5 5d251f660ab2882c03fb8909772c98ef OOo_2.0.1rc5_051215_LinuxIntel_langpack_km.tar.gz 33508180
+MD5 bfc654d1f648bfe4f6bc8d3cd2ff2431 OOo_2.0.1rc5_051215_LinuxIntel_langpack_ko.tar.gz 28349121
+MD5 f7edfbea71bd7d6b274b88405a7d85c1 OOo_2.0.1rc5_051215_LinuxIntel_langpack_lt.tar.gz 26945884
+MD5 f8b5ead2c34800c5daf049befbe321b2 OOo_2.0.1rc5_051215_LinuxIntel_langpack_nb.tar.gz 26876185
+MD5 cb662f3144e3901900bb3eec4da5ff83 OOo_2.0.1rc5_051215_LinuxIntel_langpack_nl.tar.gz 29243357
+MD5 ac9f9763415727b571da1e7700eeb69e OOo_2.0.1rc5_051215_LinuxIntel_langpack_nn.tar.gz 26878988
+MD5 329f2acab6f5fd6dab18c3a9cb80452b OOo_2.0.1rc5_051215_LinuxIntel_langpack_ns.tar.gz 26979690
+MD5 9075fd4f5e7ff55d71487a7e13dd73b6 OOo_2.0.1rc5_051215_LinuxIntel_langpack_pa-IN.tar.gz 26975391
+MD5 b620fcff302fc61015c68cd8cabf0e27 OOo_2.0.1rc5_051215_LinuxIntel_langpack_pl.tar.gz 27491702
+MD5 ccddf107e73e67f53c9cc24d282c2f84 OOo_2.0.1rc5_051215_LinuxIntel_langpack_pt-BR.tar.gz 28544286
+MD5 3f92aae050efaeb8a2cddf03e2b42b78 OOo_2.0.1rc5_051215_LinuxIntel_langpack_ru.tar.gz 29797198
+MD5 926b9282383aa7fc3d401bd4195684f5 OOo_2.0.1rc5_051215_LinuxIntel_langpack_rw.tar.gz 27544926
+MD5 0a487e82f7abc97b884876d588f66901 OOo_2.0.1rc5_051215_LinuxIntel_langpack_sh-YU.tar.gz 26835724
+MD5 961ccc5e8d8ba386e753897959058692 OOo_2.0.1rc5_051215_LinuxIntel_langpack_sk.tar.gz 28153843
+MD5 1e20279f60e81e27fd3c2dbf0eedfe78 OOo_2.0.1rc5_051215_LinuxIntel_langpack_sl.tar.gz 27307726
+MD5 ca4ecb20fdda833fc09451b5a288bb26 OOo_2.0.1rc5_051215_LinuxIntel_langpack_sr-CS.tar.gz 26938666
+MD5 6c3d67f9a76a910ce7011c502a946005 OOo_2.0.1rc5_051215_LinuxIntel_langpack_st.tar.gz 26947097
+MD5 812daedb43fae90bd31dfbc68b7f0f51 OOo_2.0.1rc5_051215_LinuxIntel_langpack_sv.tar.gz 27945879
+MD5 79655f39197e10211bf01254d94c78ef OOo_2.0.1rc5_051215_LinuxIntel_langpack_sw-TZ.tar.gz 27173032
+MD5 517af03b2b18946a798df697b3fe8148 OOo_2.0.1rc5_051215_LinuxIntel_langpack_th.tar.gz 27032761
+MD5 774e5833f08900375d888f5f2e113236 OOo_2.0.1rc5_051215_LinuxIntel_langpack_tr.tar.gz 27303612
+MD5 d99466386c8f702944fb5a0b9782a0ee OOo_2.0.1rc5_051215_LinuxIntel_langpack_vi.tar.gz 26931623
+MD5 4bda5ab83b857c107b490d2b1cdd0f5d OOo_2.0.1rc5_051215_LinuxIntel_langpack_zh-CN.tar.gz 28636381
+MD5 131c0ec8c4c18e9fe1c263ed54307845 OOo_2.0.1rc5_051215_LinuxIntel_langpack_zh-TW.tar.gz 28939560
+MD5 89801a56f083a2e481720834f59b9731 OOo_2.0.1rc5_051215_LinuxIntel_langpack_zu.tar.gz 27061106
+MD5 1d4542a3da8970c9b13a2d4872b71718 openoffice.org-ar-2.0.1-1.i586.tar.gz 13473351
+MD5 f8c5ab1e76fcde22290a2436b33bad10 openoffice.org-bn-2.0.1-1.i586.tar.gz 13425916
+MD5 62afa2a29b91c6f44816cef2ade7a4a1 openoffice.org-br-2.0.1-1.i586.tar.gz 13378890
+MD5 eccca0086872dbcf076a57b1ac2fe0f0 openoffice.org-fa-2.0.1-1.i586.tar.gz 13411935
+MD5 4a7390d1977a47b235f688f9418c287d openoffice.org-ga-2.0.1-1.i586.tar.gz 13665294
+MD5 2a65eee755337b5fcc46ff8a4587b136 openoffice.org-lo-2.0.1-1.i586.tar.gz 13470198
+MD5 3edc02bb7cefe59e83f2d08339359339 openoffice.org-lv-2.0.1-1.i586.tar.gz 13426497
+MD5 15eed44eaade6ce609694c227ad635a2 openoffice.org-mk-2.0.1-1.i586.tar.gz 14303117
+MD5 e1dadfb497aa7d45e4264704cc419b54 openoffice.org-ne-2.0.1-1.i586.tar.gz 16051577
+MD5 de353953123d2bd2cb0343c107f74bee openoffice.org-nr-2.0.1-1.i586.tar.gz 13478491
+MD5 6b63a91c539d9414f7b72a7a95f724fc openoffice.org-tn-2.0.1-1.i586.tar.gz 13434242
+MD5 46643cad7325e0110dea06b249646042 openoffice.org-xh-2.0.1-1.i586.tar.gz 13516183
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.1.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.1.ebuild
new file mode 100644
index 000000000000..ffca520b7354
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-2.0.1.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.1.ebuild,v 1.1 2005/12/21 16:26:37 suka Exp $
+
+inherit eutils fdo-mime rpm multilib
+
+IUSE="gnome java"
+
+MY_PV="${PV}rc5"
+MY_PV2="${MY_PV}_051215"
+S="${WORKDIR}/OOA680_m1_native_packed-1_en-US.8990/RPMS"
+DESCRIPTION="OpenOffice productivity suite"
+
+LANGPACK="OOo_${MY_PV2}_LinuxIntel_langpack"
+LANGPACKPATH="http://oootranslation.services.openoffice.org/pub/OpenOffice.org/${MY_PV}/${LANGPACK}"
+LANGLOC="http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/${PV}-RC5/OOo_${PV}_native_LinuxIntel_langpacks_rpm"
+LANGSUFFIX="${PV}-1.i586.tar.gz"
+
+SRC_URI="mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz
+ linguas_af? ( ${LANGPACKPATH}_af.tar.gz )
+ linguas_ar? ( ${LANGLOC}/openoffice.org-ar-${LANGSUFFIX} )
+ linguas_be_BY? ( ${LANGPACKPATH}_be-BY.tar.gz )
+ linguas_bg? ( ${LANGPACKPATH}_bg.tar.gz )
+ linguas_bn? ( ${LANGLOC}/openoffice.org-bn-${LANGSUFFIX} )
+ linguas_br? ( ${LANGLOC}/openoffice.org-br-${LANGSUFFIX} )
+ linguas_bs? ( ${LANGPACKPATH}_bs.tar.gz )
+ linguas_ca? ( ${LANGPACKPATH}_ca.tar.gz )
+ linguas_cs? ( ${LANGPACKPATH}_cs.tar.gz )
+ linguas_cy? ( ${LANGPACKPATH}_cy.tar.gz )
+ linguas_da? ( ${LANGPACKPATH}_da.tar.gz )
+ linguas_de? ( ${LANGPACKPATH}_de.tar.gz )
+ linguas_el? ( ${LANGPACKPATH}_el.tar.gz )
+ linguas_en_GB? ( ${LANGPACKPATH}_en-GB.tar.gz )
+ linguas_en_ZA? ( ${LANGPACKPATH}_en-ZA.tar.gz )
+ linguas_es? ( ${LANGPACKPATH}_es.tar.gz )
+ linguas_et? ( ${LANGPACKPATH}_et.tar.gz )
+ linguas_fa? ( ${LANGLOC}/openoffice.org-fa-${LANGSUFFIX} )
+ linguas_fi? ( ${LANGPACKPATH}_fi.tar.gz )
+ linguas_fr? ( ${LANGPACKPATH}_fr.tar.gz )
+ linguas_ga? ( ${LANGLOC}/openoffice.org-ga-${LANGSUFFIX} )
+ linguas_gu_IN? ( ${LANGPACKPATH}_gu-IN.tar.gz )
+ linguas_hi_IN? ( ${LANGPACKPATH}_hi-IN.tar.gz )
+ linguas_hr? ( ${LANGPACKPATH}_hr.tar.gz )
+ linguas_hu? ( ${LANGPACKPATH}_hu.tar.gz )
+ linguas_it? ( ${LANGPACKPATH}_it.tar.gz )
+ linguas_ja? ( ${LANGPACKPATH}_ja.tar.gz )
+ linguas_km? ( ${LANGPACKPATH}_km.tar.gz )
+ linguas_ko? ( ${LANGPACKPATH}_ko.tar.gz )
+ linguas_lo? ( ${LANGLOC}/openoffice.org-lo-${LANGSUFFIX} )
+ linguas_lt? ( ${LANGPACKPATH}_lt.tar.gz )
+ linguas_lv? ( ${LANGLOC}/openoffice.org-lv-${LANGSUFFIX} )
+ linguas_mk? ( ${LANGLOC}/openoffice.org-mk-${LANGSUFFIX} )
+ linguas_nb? ( ${LANGPACKPATH}_nb.tar.gz )
+ linguas_ne? ( ${LANGLOC}/openoffice.org-ne-${LANGSUFFIX} )
+ linguas_nl? ( ${LANGPACKPATH}_nl.tar.gz )
+ linguas_nn? ( ${LANGPACKPATH}_nn.tar.gz )
+ linguas_nr? ( ${LANGLOC}/openoffice.org-nr-${LANGSUFFIX} )
+ linguas_ns? ( ${LANGPACKPATH}_ns.tar.gz )
+ linguas_pa_IN? ( ${LANGPACKPATH}_pa-IN.tar.gz )
+ linguas_pl? ( ${LANGPACKPATH}_pl.tar.gz )
+ linguas_pt_BR? ( ${LANGPACKPATH}_pt-BR.tar.gz )
+ linguas_ru? ( ${LANGPACKPATH}_ru.tar.gz )
+ linguas_rw? ( ${LANGPACKPATH}_rw.tar.gz )
+ linguas_sh_YU? ( ${LANGPACKPATH}_sh-YU.tar.gz )
+ linguas_sk? ( ${LANGPACKPATH}_sk.tar.gz )
+ linguas_sl? ( ${LANGPACKPATH}_sl.tar.gz )
+ linguas_sr_CS? ( ${LANGPACKPATH}_sr-CS.tar.gz )
+ linguas_st? ( ${LANGPACKPATH}_st.tar.gz )
+ linguas_sv? ( ${LANGPACKPATH}_sv.tar.gz )
+ linguas_sw_TZ? ( ${LANGPACKPATH}_sw-TZ.tar.gz )
+ linguas_th? ( ${LANGPACKPATH}_th.tar.gz )
+ linguas_tn? ( ${LANGLOC}/openoffice.org-tn-${LANGSUFFIX} )
+ linguas_tr? ( ${LANGPACKPATH}_tr.tar.gz )
+ linguas_vi? ( ${LANGPACKPATH}_vi.tar.gz )
+ linguas_xh? ( ${LANGLOC}/openoffice.org-xh-${LANGSUFFIX} )
+ linguas_zh_CN? ( ${LANGPACKPATH}_zh-CN.tar.gz )
+ linguas_zh_TW? ( ${LANGPACKPATH}_zh-TW.tar.gz )
+ linguas_zu? ( ${LANGPACKPATH}_zu.tar.gz )"
+
+HOMEPAGE="http://www.openoffice.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="!app-office/openoffice
+ || ( x11-libs/libXaw virtual/x11 )
+ sys-libs/glibc
+ >=dev-lang/perl-5.0
+ app-arch/zip
+ app-arch/unzip
+ java? ( !amd64? ( >=virtual/jre-1.4.1 )
+ amd64? ( app-emulation/emul-linux-x86-java ) )
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )
+ linguas_ja? ( >=media-fonts/kochi-substitute-20030809-r3 )
+ linguas_zh_CN? ( >=media-fonts/arphicfonts-0.1-r2 )
+ linguas_zh_TW? ( >=media-fonts/arphicfonts-0.1-r2 )"
+
+DEPEND="${RDEPEND}
+ sys-apps/findutils"
+
+PROVIDE="virtual/ooo"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in base calc core01 core02 core03 core03u core04 core04u core05 core05u core06 core07 core08 core09 core10 draw impress math writer graphicfilter pyuno spellcheck testtool xsltfilter ; do
+ rpm_unpack ${S}/openoffice.org-${i}-${PV}-1.i586.rpm
+ done
+
+ rpm_unpack ${S}/desktop-integration/openoffice.org-freedesktop-menus-${PV}-1.noarch.rpm
+
+ use gnome && rpm_unpack ${S}/openoffice.org-gnome-integration-${PV}-1.i586.rpm
+ use java && rpm_unpack ${S}/openoffice.org-javafilter-${PV}-1.i586.rpm && rpm_unpack ${S}/openoffice.org-emailmerge-${PV}-1.i586.rpm
+
+ strip-linguas en af ar be_BY bg bn br bs ca cs cy da de el en_GB en_ZA es et fa fi fr ga gu_IN hi_IN hr hu it ja km ko lo lt lv mk nb ne nl nn nr ns pa_IN pl pt_BR ru rw sh_YU sk sl sr_CS st sv sw_TZ th tn tr vi xh zh_CN zh_TW zu
+
+ for i in ${LINGUAS}; do
+ i="${i/_/-}"
+
+ #workaround for upstream packaging mismatch
+ if [ -d ${WORKDIR}/OOA680_m1_native_packed-1_${i}.8990 ] ; then
+ tar -xzf ${WORKDIR}/OOA680_m1_native_packed-1_${i}.8990/RPMS/openoffice.org-${i}-${LANGSUFFIX} || die
+ fi
+
+ if [ ${i} != "en" ] ; then
+ rpm_unpack openoffice.org-${i}-${PV}-*.i586.rpm
+ rpm_unpack openoffice.org-${i}-help-${PV}-*.i586.rpm
+ rpm_unpack openoffice.org-${i}-res-${PV}-*.i586.rpm
+ fi
+ done
+
+}
+
+src_install () {
+
+ #Multilib install dir magic for AMD64
+ has_multilib_profile && ABI=x86
+ INSTDIR="/usr/$(get_libdir)/openoffice"
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ mv ${WORKDIR}/opt/openoffice.org2.0/* ${D}${INSTDIR}
+
+ #Menu entries, icons and mime-types
+ cd ${D}${INSTDIR}/share/xdg/
+ sed -i -e s/'Exec=openoffice.org-2.0-printeradmin'/'Exec=oopadmin2'/g printeradmin.desktop || die
+
+ for desk in base calc draw impress math printeradmin writer; do
+ mv ${desk}.desktop openoffice.org-2.0-${desk}.desktop
+ sed -i -e s/openoffice.org-2.0/ooffice2/g openoffice.org-2.0-${desk}.desktop || die
+ sed -i -e s/openofficeorg-20-${desk}/ooo-${desk}2/g openoffice.org-2.0-${desk}.desktop || die
+ domenu openoffice.org-2.0-${desk}.desktop
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/usr/share/icons/gnome/48x48/apps/openofficeorg-20-${desk}.png ooo-${desk}2.png
+ done
+
+ insinto /usr/share/mime/packages
+ doins ${WORKDIR}/usr/share/mime/packages/openoffice.org.xml
+
+ # Install wrapper script
+ newbin ${FILESDIR}/${PV}/ooo-wrapper2 ooffice2
+ sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
+ sed -i -e "s|INSTDIR|${INSTDIR}|g" ${D}/usr/bin/ooffice2 || die
+
+ # Component symlinks
+ for app in base calc draw fromtemplate impress math web writer; do
+ dosym ooffice2 /usr/bin/oo${app}2
+ done
+
+ dosym ${INSTDIR}/program/spadmin.bin /usr/bin/oopadmin2
+
+ # Change user install dir
+ sed -i -e s/.openoffice.org2/.ooo-2.0/g ${D}${INSTDIR}/program/bootstraprc || die
+
+ # Non-java weirdness see bug #99366
+ use !java && rm -f ${D}${INSTDIR}/program/javaldx
+}
+
+pkg_postinst() {
+
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ [ -x /sbin/chpax ] && [ -e /usr/lib/openoffice/program/soffice.bin ] && chpax -zm /usr/lib/openoffice/program/soffice.bin
+
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice2"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oobase2, oocalc2, oodraw2, oofromtemplate2, ooimpress2, oomath2,"
+ einfo " ooweb2 or oowriter2"
+}