summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-09-01 07:30:51 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-09-01 07:30:51 +0000
commit0473ccb7cff4010b5949a39f18a19899978216f5 (patch)
treec38ee319cdf0dcef6fd62352ebc1ca791a61d1fb /app-sci
parentadded clisp and gcl use flags for maxima (diff)
downloadhistorical-0473ccb7cff4010b5949a39f18a19899978216f5.tar.gz
historical-0473ccb7cff4010b5949a39f18a19899978216f5.tar.bz2
historical-0473ccb7cff4010b5949a39f18a19899978216f5.zip
added support for any combination of clisp, cmucl and gcl
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/maxima/ChangeLog5
-rw-r--r--app-sci/maxima/Manifest4
-rw-r--r--app-sci/maxima/maxima-5.9.0-r1.ebuild30
3 files changed, 27 insertions, 12 deletions
diff --git a/app-sci/maxima/ChangeLog b/app-sci/maxima/ChangeLog
index 19bd29509296..e1c42b17d8c2 100644
--- a/app-sci/maxima/ChangeLog
+++ b/app-sci/maxima/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/maxima
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/ChangeLog,v 1.2 2003/08/07 05:40:32 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/ChangeLog,v 1.3 2003/09/01 07:30:40 george Exp $
+
+ 31 Aug 2003; George Shapovalov <george@gentoo.org> maxima-5.9.0-r1.ebuild :
+ few more improvements from #16529. Now supports clisp, cmucl and gcl in any combination
*maxima-5.9.0-r1 (06 Aug 2003)
diff --git a/app-sci/maxima/Manifest b/app-sci/maxima/Manifest
index 16027161bf2b..d97614abd482 100644
--- a/app-sci/maxima/Manifest
+++ b/app-sci/maxima/Manifest
@@ -1,5 +1,5 @@
-MD5 6f9754d7fb47c441d90e8f1fc442e834 maxima-5.9.0-r1.ebuild 2146
-MD5 7fb187ece4f8b396b83c055bd268851c ChangeLog 832
+MD5 8fc6cd03010be3cf3ca80c0b261dd014 maxima-5.9.0-r1.ebuild 2477
+MD5 91e4056f3b21a05f735750de736b1df7 ChangeLog 1001
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 e12a7f825afe21a3cdb5fea002819fea maxima-5.9.0.ebuild 823
MD5 aaa91ea4812a84a1054b82e69d3fe05b files/digest-maxima-5.9.0-r1 65
diff --git a/app-sci/maxima/maxima-5.9.0-r1.ebuild b/app-sci/maxima/maxima-5.9.0-r1.ebuild
index 27c41754716e..6bbd513e1624 100644
--- a/app-sci/maxima/maxima-5.9.0-r1.ebuild
+++ b/app-sci/maxima/maxima-5.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/maxima-5.9.0-r1.ebuild,v 1.1 2003/08/07 05:40:32 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/maxima-5.9.0-r1.ebuild,v 1.2 2003/09/01 07:30:40 george Exp $
DESCRIPTION="Free computer algebra environment, based on Macsyma"
HOMEPAGE="http://maxima.sourceforge.net/"
@@ -10,23 +10,35 @@ LICENSE="GPL-2 AECA"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE="cmucl tetex emacs auctex"
+IUSE="cmucl clisp gcl tetex emacs auctex"
-DEPEND="|| ( cmucl? ( dev-lisp/cmucl-bin ) dev-lisp/clisp )
- tetex? ( app-text/tetex )
+
+DEPEND="tetex? ( app-text/tetex )
emacs? ( app-editors/emacs )
auctex? ( app-emacs/auctex )
- >=sys-apps/texinfo-4.3"
+ >=sys-apps/texinfo-4.3
+ !clisp? ( !gcl? ( !cmucl? ( dev-lisp/cmucl-bin ) ) )
+ clisp? ( dev-lisp/clisp )
+ cmucl? ( dev-lisp/cmucl-bin )
+ gcl? ( dev-lisp/gcl )"
RDEPEND=">=dev-lang/tk-8.3.3"
src_compile() {
local myconf=""
- if [ -n "$(use cmucl)" ]; then
- myconf="${myconf} --enable-cmucl"
+ if [ -n "$(use cmucl)" ] || [ -n "$(use clisp)" ] || [ -n "$(use gcl)" ]; then
+ if [ -n "$(use cmucl)" ]; then
+ myconf="${myconf} --enable-cmucl"
+ fi
+ if [ -n "$(use clisp)" ]; then
+ myconf="${myconf} --enable-clisp"
+ fi
+ if [ -n "$(use gcl)" ]; then
+ myconf="${myconf} --enable-gcl"
+ fi
else
- myconf="${myconf} --enable-clisp"
+ myconf="${myconf} --enable-cmucl"
fi
./configure --prefix=/usr ${myconf} || die
@@ -65,7 +77,7 @@ pkg_postinst() {
if [ -n "`use emacs`" ]
then
einfo "In order to use Maxima with emacs, add the following to your .emacs file:
- (setq load-path (cons "/usr/share/maxima/5.9.0/emacs" load-path))
+ (setq load-path (cons "/usr/share/maxima/5.9.0/emacs" load-path))
(autoload 'maxima-mode "maxima" "Maxima mode" t)
(autoload 'maxima "maxima" "Maxima interactive" t)
(setq auto-mode-alist (cons '("\\.max" . maxima-mode) auto-mode-alist))