summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-11-23 22:34:22 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-11-23 22:34:22 +0000
commit0d779ecaf01a8cf74a901e3b7addffc433e76701 (patch)
tree9ae1703e450c9e0d429ffeed9689384d608ef6da /dev-libs/libindicate/libindicate-0.2.3.ebuild
parentClean up old revision, bug #285760 and bug #292252. (diff)
downloadhistorical-0d779ecaf01a8cf74a901e3b7addffc433e76701.tar.gz
historical-0d779ecaf01a8cf74a901e3b7addffc433e76701.tar.bz2
historical-0d779ecaf01a8cf74a901e3b7addffc433e76701.zip
Fix bug #294279, skip test programs installed in /usr/libexec and respect $PF for examples code, many thanks to Flameeyes
Package-Manager: portage-2.2_rc51/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libindicate/libindicate-0.2.3.ebuild')
-rw-r--r--dev-libs/libindicate/libindicate-0.2.3.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/libindicate/libindicate-0.2.3.ebuild b/dev-libs/libindicate/libindicate-0.2.3.ebuild
index 2aaeca831344..068ce53a0995 100644
--- a/dev-libs/libindicate/libindicate-0.2.3.ebuild
+++ b/dev-libs/libindicate/libindicate-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-0.2.3.ebuild,v 1.3 2009/10/30 00:02:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-0.2.3.ebuild,v 1.4 2009/11/23 22:34:22 mrpouet Exp $
EAPI=2
@@ -32,12 +32,17 @@ src_prepare() {
eautoreconf
}
src_configure() {
+ local my_conf
+
# gobject-instrospection is a nightmare in this package, it's fixable for libindicate
# and not for libindicate-gtk, disable it until its fixed on upstream
- econf --disable-dependency-tracking \
- --disable-gobject-introspection \
- $(use_enable gtk) \
- $(use_enable doc)
+ my_conf="--disable-dependency-tracking
+ --disable-gobject-introspection
+ $(use_enable gtk)
+ $(use_enable doc)"
+ # Fix bug 294279
+ use doc && my_conf="$my_conf --docdir=/usr/share/doc/${PF}"
+ econf $my_conf
}
src_test() {
emake check || die "testsuite failed"