summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-12-03 03:46:14 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-12-03 03:46:14 +0000
commita78f4a1b7c40a40de54f3c096fb4ac1e687c25de (patch)
treee65e3c1aafdb0b44f3cccc5f71d7b76318474d54 /dev-lisp/cl-who
parent*** empty log message *** (diff)
downloadhistorical-a78f4a1b7c40a40de54f3c096fb4ac1e687c25de.tar.gz
historical-a78f4a1b7c40a40de54f3c096fb4ac1e687c25de.tar.bz2
historical-a78f4a1b7c40a40de54f3c096fb4ac1e687c25de.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-who')
-rw-r--r--dev-lisp/cl-who/Manifest6
-rw-r--r--dev-lisp/cl-who/cl-who-0.4.0.ebuild35
-rw-r--r--dev-lisp/cl-who/files/digest-cl-who-0.4.01
-rw-r--r--dev-lisp/cl-who/metadata.xml9
4 files changed, 47 insertions, 4 deletions
diff --git a/dev-lisp/cl-who/Manifest b/dev-lisp/cl-who/Manifest
index 034c9bce00a9..cc828fe78b45 100644
--- a/dev-lisp/cl-who/Manifest
+++ b/dev-lisp/cl-who/Manifest
@@ -1,8 +1,6 @@
-MD5 8f27f4a086cfe919af084c41cf7ee3b1 ChangeLog 408
+MD5 81614165a28cf632b8773fbb492a5c7f ChangeLog 525
MD5 c65c6f01ae7b124f72ae236ff614b934 cl-who-0.3.0.ebuild 1115
MD5 9278f70e7af84494437f1b19f0039c7f metadata.xml 661
-MD5 16c6039409c57906f0599eed4bb27fdd cl-who-0.4.0.ebuild 846
-MD5 c65c6f01ae7b124f72ae236ff614b934 cl-who-0.4.0.ebuild~ 1115
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml.~1.1.~ 164
+MD5 72985270801e8357eb47e813373cc325 cl-who-0.4.0.ebuild 839
MD5 e8bfc2f726389e4690ccfb89886d6fff files/digest-cl-who-0.3.0 63
MD5 cbfd26481bdf2cfb043149907ab7e4c9 files/digest-cl-who-0.4.0 68
diff --git a/dev-lisp/cl-who/cl-who-0.4.0.ebuild b/dev-lisp/cl-who/cl-who-0.4.0.ebuild
new file mode 100644
index 000000000000..3dc9c5695570
--- /dev/null
+++ b/dev-lisp/cl-who/cl-who-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-who/cl-who-0.4.0.ebuild,v 1.1 2003/12/03 03:46:11 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION='CL-WHO (is yet another Lisp Markup Language.'
+HOMEPAGE="http://weitz.de/cl-who/
+ http://www.cliki.net/cl-who"
+SRC_URI="mirror://gentoo/${PN}_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-who
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG INSTALLATION
+ dohtml doc/*.html
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-who/files/digest-cl-who-0.4.0 b/dev-lisp/cl-who/files/digest-cl-who-0.4.0
new file mode 100644
index 000000000000..d000e01f7334
--- /dev/null
+++ b/dev-lisp/cl-who/files/digest-cl-who-0.4.0
@@ -0,0 +1 @@
+MD5 802467426797f907aad870b78f05fd28 cl-who_0.4.0.orig.tar.gz 14888
diff --git a/dev-lisp/cl-who/metadata.xml b/dev-lisp/cl-who/metadata.xml
index f418045b09c8..999dcca9534e 100644
--- a/dev-lisp/cl-who/metadata.xml
+++ b/dev-lisp/cl-who/metadata.xml
@@ -2,4 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>common-lisp</herd>
+<longdescription>
+There are plenty of Lisp Markup Languages out there - every Lisp
+programmer seems to write at least one during his career - and CL-WHO
+(where WHO means "with-html-output" for want of a better acronym) is
+probably just as good or bad as the next one. They are all more or
+less similar in that they provide convenient means to convert
+S-expressions intermingled with code into (X)HTML, XML, or whatever
+but differ with respect to syntax, implementation, and
+API.</longdescription>
</pkgmetadata>