summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-21 20:12:22 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-21 20:12:22 +0000
commit118b0959b8631ab5380b1da036f9838f209950b5 (patch)
tree1439656940bb12457887eb76e95482294ebd0c46 /dev-ruby/activeresource
parentFix tests when Rails 3 is also present. (diff)
downloadhistorical-118b0959b8631ab5380b1da036f9838f209950b5.tar.gz
historical-118b0959b8631ab5380b1da036f9838f209950b5.tar.bz2
historical-118b0959b8631ab5380b1da036f9838f209950b5.zip
Version bump for Rails 2.3.11.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.11.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 480c0d78f537..b7fb185fca13 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.76 2011/02/21 20:04:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.77 2011/02/21 20:11:22 graaff Exp $
+
+*activeresource-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
activeresource-2.3.10.ebuild, +files/activeresource-2.3.10-rails3.patch:
diff --git a/dev-ruby/activeresource/activeresource-2.3.11.ebuild b/dev-ruby/activeresource/activeresource-2.3.11.ebuild
new file mode 100644
index 000000000000..25e0721552c0
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.11.ebuild,v 1.1 2011/02/21 20:11:22 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}