summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-07-20 17:57:47 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-07-20 17:57:47 +0000
commit051cbca101b72be465ed321493105f014ffcc86e (patch)
tree63b856e44c3f40028e58049a9666248586f254e9 /dev-tinyos/nesc/nesc-1.2.1.ebuild
parentRemoving old ebuilds. Adding runtime dependency on dev-perl/XML-Simple, fixin... (diff)
downloadhistorical-051cbca101b72be465ed321493105f014ffcc86e.tar.gz
historical-051cbca101b72be465ed321493105f014ffcc86e.tar.bz2
historical-051cbca101b72be465ed321493105f014ffcc86e.zip
Removing old ebuilds. Adding runtime dependency on dev-perl/XML-Simple, fixing bug #141176. Thanks to Aurélien Francillon <aurelien.francillon@inrialpes.fr> for reporting. Bumping ebuild revisions due to runtime dependency changed.
Package-Manager: portage-2.1.1_pre3-r1
Diffstat (limited to 'dev-tinyos/nesc/nesc-1.2.1.ebuild')
-rw-r--r--dev-tinyos/nesc/nesc-1.2.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-tinyos/nesc/nesc-1.2.1.ebuild b/dev-tinyos/nesc/nesc-1.2.1.ebuild
deleted file mode 100644
index 9881121956a0..000000000000
--- a/dev-tinyos/nesc/nesc-1.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.1.ebuild,v 1.3 2006/03/13 18:51:16 sanchan Exp $
-
-inherit eutils
-
-DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
-HOMEPAGE="http://nescc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="doc"
-DEPEND=">=dev-lang/perl-5.8.5-r2
- >=dev-tinyos/tos-1.1.0"
-RDEPEND=">=dev-lang/perl-5.8.5-r2
- >=dev-tinyos/tos-1.1.0"
-
-
-pkg_setup() {
- if [ -z "${TOSDIR}" ]
- then
- # best to make an assumption
- export TOSDIR=/usr/src/tinyos-1.x/tos
- fi
-
- if [ ! -d "${TOSDIR}" ]
- then
- eerror "In order to compile nesc you have to set the"
- eerror "\$TOSDIR environment properly."
- eerror ""
- eerror "You can achieve this by emerging >=dev-tinyos/tos-1.1.15"
- eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
- die "Couldn't find a valid TinyOS home"
- else
- einfo "Building nesC for ${TOSDIR}"
- fi
-}
-
-src_compile() {
- econf --disable-dependency-tracking || die "econf failed"
- # language setting needed, otherwise gcc version
- # will sometimes not be detected right
- LANGUAGE=C emake || die "emake failed"
-}
-
-src_install() {
- LANGUAGE=C einstall || die "einstall failed"
- if use doc
- then
- dohtml -r -a html,jpg,pdf,txt doc/*
- fi
- dodoc README
-}