summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-24 02:52:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-24 02:52:12 +0000
commit38f90956dae5430fdafd1b0c6a98a96e41e0da6c (patch)
tree67edb2bc9f5ba2f076a7c2ec2c2e9f7410d1caa1 /dev-util/cppunit
parentstabilize #106930 (diff)
downloadhistorical-38f90956dae5430fdafd1b0c6a98a96e41e0da6c.tar.gz
historical-38f90956dae5430fdafd1b0c6a98a96e41e0da6c.tar.bz2
historical-38f90956dae5430fdafd1b0c6a98a96e41e0da6c.zip
fix underquoted definition of AM_PATH_CPPUNIT warning
Package-Manager: portage-2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/Manifest13
-rw-r--r--dev-util/cppunit/cppunit-1.10.2.ebuild23
-rw-r--r--dev-util/cppunit/files/cppunit-1.10.2-m4.patch11
3 files changed, 32 insertions, 15 deletions
diff --git a/dev-util/cppunit/Manifest b/dev-util/cppunit/Manifest
index eadbe433e590..bd012174a31c 100644
--- a/dev-util/cppunit/Manifest
+++ b/dev-util/cppunit/Manifest
@@ -2,15 +2,16 @@
Hash: SHA1
MD5 c4c708e3dc384f836a21bfea63ae3288 metadata.xml 162
+MD5 fab92a2dfa6317ee68fe648a89dd63fc cppunit-1.10.2.ebuild 1017
MD5 2088e693ce5dc24d9d17c07ab0abe304 cppunit-1.8.0.ebuild 915
-MD5 41a5a6e8ffd25ba170b4907c4aa022d7 cppunit-1.10.2.ebuild 971
MD5 1bd2626402c56ff5372577b3638fd5f2 ChangeLog 1619
-MD5 b71249733f097340c7893dfdc0538885 files/digest-cppunit-1.8.0 65
MD5 2f66c625e1f7de63458cfb987e9b0d9d files/digest-cppunit-1.10.2 66
+MD5 5a6b916219a39b44961b68d66037912c files/cppunit-1.10.2-m4.patch 304
+MD5 b71249733f097340c7893dfdc0538885 files/digest-cppunit-1.8.0 65
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1-ecc0.1.6 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC4P+ZKRy60XGEcJIRAm6/AKCNbvjbxr9eM1v1hvFjUW2HVwRJdACfRN16
-VYV83TgHGlY/5GdL/y9Dtjc=
-=RnI1
+iD8DBQFDNL+IgIKl8Uu19MoRAjFmAJ9U+K8uRonrcajhnDtEgkiUnhRq1ACdF2cb
+mRsfaWJtiA1HtZOP5YKf2Yw=
+=+rWv
-----END PGP SIGNATURE-----
diff --git a/dev-util/cppunit/cppunit-1.10.2.ebuild b/dev-util/cppunit/cppunit-1.10.2.ebuild
index c81f92a5bed3..8ddb4055fd4f 100644
--- a/dev-util/cppunit/cppunit-1.10.2.ebuild
+++ b/dev-util/cppunit/cppunit-1.10.2.ebuild
@@ -1,31 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.9 2005/07/22 14:15:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.10 2005/09/24 02:52:12 vapier Exp $
-IUSE="doc"
+inherit eutils
-DESCRIPTION="CppUnit is the C++ port of the famous JUnit framework for unit testing."
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="http://cppunit.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-
-RESTRICT="maketest"
+IUSE="doc"
+RESTRICT="test"
DEPEND="doc? ( app-doc/doxygen )
media-gfx/graphviz"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+}
+
src_compile() {
- econf `use_enable doc doxygen` || die "configure failed"
+ econf $(use_enable doc doxygen) || die "configure failed"
emake || die
- #make check || die
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS COPYING NEWS README THANKS TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
# the package automatically puts its docs into /usr/share/cppunit
# move them to the standard location and clean up
mv ${D}/usr/share/cppunit/html ${D}/usr/share/doc/${PF}
diff --git a/dev-util/cppunit/files/cppunit-1.10.2-m4.patch b/dev-util/cppunit/files/cppunit-1.10.2-m4.patch
new file mode 100644
index 000000000000..2d2a9bf1a4fe
--- /dev/null
+++ b/dev-util/cppunit/files/cppunit-1.10.2-m4.patch
@@ -0,0 +1,11 @@
+--- cppunit.m4
++++ cppunit.m4
+@@ -1,7 +1,7 @@
+ dnl
+ dnl AM_PATH_CPPUNIT(MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+ dnl
+-AC_DEFUN(AM_PATH_CPPUNIT,
++AC_DEFUN([AM_PATH_CPPUNIT],
+ [
+
+ AC_ARG_WITH(cppunit-prefix,[ --with-cppunit-prefix=PFX Prefix where CppUnit is installed (optional)],