summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-11-05 05:40:41 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-11-05 05:40:41 +0000
commit5501c1e864e3565474616459d3ff87b94050b59f (patch)
tree7cdbf40fa561247077d622179f630c9559f49f61 /games-sports
parentRemove old files, clean up some configuration files repoman was complaining a... (diff)
downloadhistorical-5501c1e864e3565474616459d3ff87b94050b59f.tar.gz
historical-5501c1e864e3565474616459d3ff87b94050b59f.tar.bz2
historical-5501c1e864e3565474616459d3ff87b94050b59f.zip
Added ~ppc and gcc 3.4 fixes.
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/gracer/ChangeLog6
-rw-r--r--games-sports/gracer/Manifest5
-rw-r--r--games-sports/gracer/files/gracer-gcc-3.4.patch120
-rw-r--r--games-sports/gracer/gracer-0.1.5.ebuild5
4 files changed, 131 insertions, 5 deletions
diff --git a/games-sports/gracer/ChangeLog b/games-sports/gracer/ChangeLog
index f651ace332fa..76a6938dcc5e 100644
--- a/games-sports/gracer/ChangeLog
+++ b/games-sports/gracer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/gracer
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.7 2004/06/28 17:23:29 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.8 2004/11/05 05:40:41 josejx Exp $
+
+ 05 Nov 2004; Joseph Jezak <josejx@gentoo.org> +files/gracer-gcc-3.4.patch,
+ gracer-0.1.5.ebuild:
+ Added ~ppc and gcc 3.4 fixes.
28 Jun 2004; Jason Eric Huebel <jhuebel@gentoo.org> gracer-0.1.5.ebuild:
gnuconfig_update, ~amd64
diff --git a/games-sports/gracer/Manifest b/games-sports/gracer/Manifest
index 59a0889d5941..9e00f39b8295 100644
--- a/games-sports/gracer/Manifest
+++ b/games-sports/gracer/Manifest
@@ -1,5 +1,6 @@
-MD5 b05757f18416f3e96eaad7594ba95814 ChangeLog 835
-MD5 8ca94c4b66a26f5c55ded56a97892d00 gracer-0.1.5.ebuild 1213
+MD5 5e72b3275f8445a6d17eaf4f6f2e9f91 ChangeLog 967
+MD5 ce818724ad1150a0ab806bdd4c695570 gracer-0.1.5.ebuild 1257
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 f978345d5296e011b2bfbd03e2820588 files/0.1.5-gldefs.patch 1068
MD5 7d4c79d23fc5bab84c8ebb7f8a295f6c files/digest-gracer-0.1.5 64
+MD5 24914a3740a023f755f840b31eba9a98 files/gracer-gcc-3.4.patch 1755
diff --git a/games-sports/gracer/files/gracer-gcc-3.4.patch b/games-sports/gracer/files/gracer-gcc-3.4.patch
new file mode 100644
index 000000000000..354f9865a655
--- /dev/null
+++ b/games-sports/gracer/files/gracer-gcc-3.4.patch
@@ -0,0 +1,120 @@
+--- src/glbind.c.old 2004-11-05 01:15:07.141221016 +0000
++++ src/glbind.c 2004-11-05 01:15:32.808319024 +0000
+@@ -2150,6 +2150,7 @@
+ return 3;
+
+ default:
++ ;
+ }
+
+ ERROR:
+@@ -2889,6 +2890,7 @@
+ return 6;
+
+ default:
++ ;
+ }
+
+ ERROR:
+@@ -3081,6 +3083,7 @@
+ return 4;
+
+ default:
++ ;
+ }
+
+ ERROR:
+--- src/glutwidgets.c.old 2004-11-05 01:17:17.941336376 +0000
++++ src/glutwidgets.c 2004-11-05 01:18:42.059548464 +0000
+@@ -255,6 +255,7 @@
+ widget->width += (width - screen_width);
+ break;
+ default:
++ ;
+ }
+ switch (widget->anchor & GR_VERTICAL_MASK) {
+ case GR_BOTTOM:
+@@ -268,6 +269,7 @@
+ widget->height += (width - screen_height);
+ break;
+ default:
++ ;
+ }
+ glut_widget_calc_bbox (widget);
+ }
+@@ -327,6 +329,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -504,6 +507,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -1299,6 +1303,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -1571,6 +1576,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ glColor4fv (widget->fg_color[GR_STATE_NORMAL]);
+--- src/gr_world.c.old 2004-11-05 01:19:30.766143936 +0000
++++ src/gr_world.c 2004-11-05 01:19:07.717647840 +0000
+@@ -169,6 +169,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ tlist = entry->triggers;
+--- ac2scene/ac2scene.c.old 2004-11-05 01:13:55.845059680 +0000
++++ ac2scene/ac2scene.c 2004-11-05 01:14:32.526483256 +0000
+@@ -162,6 +162,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ return 0;
+@@ -234,6 +235,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ return 0;
+@@ -316,6 +318,7 @@
+ }
+ break;
+ default:
++ ;
+ }
+
+ return 0;
+@@ -399,6 +402,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
diff --git a/games-sports/gracer/gracer-0.1.5.ebuild b/games-sports/gracer/gracer-0.1.5.ebuild
index 397f2c72ede2..5d0f4520c46f 100644
--- a/games-sports/gracer/gracer-0.1.5.ebuild
+++ b/games-sports/gracer/gracer-0.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.7 2004/06/28 17:23:29 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.8 2004/11/05 05:40:41 josejx Exp $
inherit gnuconfig games eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/gracer/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~sparc ~amd64"
+KEYWORDS="x86 ~sparc ~amd64 ~ppc"
IUSE="gif jpeg png joystick"
RDEPEND="virtual/x11
@@ -29,6 +29,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}/${PV}-gldefs.patch"
+ epatch ${FILESDIR}/${PN}-gcc-3.4.patch
}
src_compile() {