summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-05 04:47:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-05 04:47:31 +0000
commitaf1399228d1959dca2602b52e9d6f5fa094e6e82 (patch)
treebae9439b2fbd21e1adba16fa216eff23c856c214 /games-util/uz2unpack
parentremove old version (diff)
downloadhistorical-af1399228d1959dca2602b52e9d6f5fa094e6e82.tar.gz
historical-af1399228d1959dca2602b52e9d6f5fa094e6e82.tar.bz2
historical-af1399228d1959dca2602b52e9d6f5fa094e6e82.zip
tidy
Package-Manager: portage-2.0.54
Diffstat (limited to 'games-util/uz2unpack')
-rw-r--r--games-util/uz2unpack/Manifest4
-rw-r--r--games-util/uz2unpack/uz2unpack-0.1.ebuild13
2 files changed, 8 insertions, 9 deletions
diff --git a/games-util/uz2unpack/Manifest b/games-util/uz2unpack/Manifest
index 6b8c85482194..330b560774ba 100644
--- a/games-util/uz2unpack/Manifest
+++ b/games-util/uz2unpack/Manifest
@@ -1,4 +1,4 @@
MD5 7735de0f905eea08d4bcc69ea8101c85 ChangeLog 547
-MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
-MD5 bc0ed2fd2811a1066b4031faab1c36e6 uz2unpack-0.1.ebuild 763
MD5 7b0307cbdb762204f2f77ffa967c2744 files/digest-uz2unpack-0.1 64
+MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
+MD5 61b67591e3b7225c6300e58418060275 uz2unpack-0.1.ebuild 800
diff --git a/games-util/uz2unpack/uz2unpack-0.1.ebuild b/games-util/uz2unpack/uz2unpack-0.1.ebuild
index f302c4640ecc..a774ff9d7672 100644
--- a/games-util/uz2unpack/uz2unpack-0.1.ebuild
+++ b/games-util/uz2unpack/uz2unpack-0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/uz2unpack/uz2unpack-0.1.ebuild,v 1.6 2005/07/19 08:18:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/uz2unpack/uz2unpack-0.1.ebuild,v 1.7 2006/02/05 04:47:31 mr_bones_ Exp $
+
+inherit toolchain-funcs
DESCRIPTION="UZ2 Decompressor for UT2003/UT2004"
HOMEPAGE="http://icculus.org/cgi-bin/ezmlm/ezmlm-cgi?42:mss:1013:200406:kikgppboefcimdbadcdo"
@@ -9,23 +11,20 @@ SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-RESTRICT=""
IUSE=""
-DEPEND=""
-RDEPEND=""
+DEPEND="sys-libs/zlib"
pkg_setup() {
einfo "This package is required for ut2003 and ut2004."
}
src_compile() {
- gcc -o ${PN} -Wall ${PN}.c -lz || die "Error compiling"
+ $(tc-getCC) -o ${PN} ${CFLAGS} ${PN}.c -lz || die "Error compiling"
}
src_install() {
- dodir /usr/bin
exeinto /usr/bin
- doexe uz2unpack
+ doexe uz2unpack || die "doexe failed"
dodoc README
}