summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-03-09 16:35:55 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-03-09 16:35:55 +0000
commitf063d12107f1513ab15d3bc9ae6fc79ff5161916 (patch)
treea91f8e35bf2050a96a99dede369d86902028aa06 /kde-base/kdebindings
parentMarking stable on x86 (diff)
downloadhistorical-f063d12107f1513ab15d3bc9ae6fc79ff5161916.tar.gz
historical-f063d12107f1513ab15d3bc9ae6fc79ff5161916.tar.bz2
historical-f063d12107f1513ab15d3bc9ae6fc79ff5161916.zip
Version bump
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/ChangeLog7
-rw-r--r--kde-base/kdebindings/Manifest4
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.2.11
-rw-r--r--kde-base/kdebindings/kdebindings-3.2.1.ebuild55
4 files changed, 65 insertions, 2 deletions
diff --git a/kde-base/kdebindings/ChangeLog b/kde-base/kdebindings/ChangeLog
index ae43e326bfbf..a5e1d3879ec4 100644
--- a/kde-base/kdebindings/ChangeLog
+++ b/kde-base/kdebindings/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdebindings
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/ChangeLog,v 1.55 2004/03/01 12:35:24 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/ChangeLog,v 1.56 2004/03/09 16:35:55 caleb Exp $
+
+*kdebindings-3.2.1 (09 Mar 2004)
+
+ 09 Mar 2004; Caleb Tennis <caleb@gentoo.org> kdebindings-3.2.1.ebuild:
+ Version bump
29 Feb 2004; Jason Wever <weeve@gentoo.org> kdebindings-3.2.0.ebuild:
Marked stable on sparc.
diff --git a/kde-base/kdebindings/Manifest b/kde-base/kdebindings/Manifest
index 9f2e187a2eb6..ca448c0901e5 100644
--- a/kde-base/kdebindings/Manifest
+++ b/kde-base/kdebindings/Manifest
@@ -1,11 +1,13 @@
MD5 61ac5703b5b1e9225b7bb38b369ae1f2 kdebindings-3.2.0.ebuild 1583
MD5 0c34b5687ff5f3f9e563c0ccd33310e2 kdebindings-3.1.4.ebuild 1570
MD5 f5217ebf5493c874327e2941c5ff6e77 kdebindings-3.0.5b.ebuild 1149
+MD5 bc6bdd52fb6ccf096024a8c687d6b463 kdebindings-3.2.1.ebuild 1586
MD5 76d49185a5bdcd17537cb0672b0ce663 kdebindings-3.1.5.ebuild 1413
-MD5 9a5fdd6b39becda8c4a266f47a004abf ChangeLog 7305
+MD5 a9eef7b4fa69acbbe6550ea4ede166c9 ChangeLog 7429
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
MD5 3a2ce91840687906d62b2072006c0374 files/digest-kdebindings-3.1.4 71
MD5 d4f762ee4e56e0866b0e10f823be10d0 files/digest-kdebindings-3.1.5 71
MD5 89aa22d33f65e9013b6b99ef35554e43 files/digest-kdebindings-3.2.0 72
+MD5 8ee5f9bbe727ea1190960ddf113364ab files/digest-kdebindings-3.2.1 72
MD5 823592dd45da38fd48dd11d40e5bbb91 files/digest-kdebindings-3.0.5b 220
MD5 452eac66c774d6c287648f4f68d6aa36 files/kdebindings-3.0.5a-qt31.diff 76610
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.2.1 b/kde-base/kdebindings/files/digest-kdebindings-3.2.1
new file mode 100644
index 000000000000..36d2ad84a9c5
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.2.1
@@ -0,0 +1 @@
+MD5 d9bd456cb3896bf652a21c66a8f6260f kdebindings-3.2.1.tar.bz2 10831837
diff --git a/kde-base/kdebindings/kdebindings-3.2.1.ebuild b/kde-base/kdebindings/kdebindings-3.2.1.ebuild
new file mode 100644
index 000000000000..bac6c8b8ac2d
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.2.1.ebuild,v 1.1 2004/03/09 16:35:55 caleb Exp $
+# TODO: add gnustep, objc bindings
+
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE library bindings for languages other than c++"
+
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~amd64"
+IUSE="mozilla java python ruby gtk"
+
+newdepend "=kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ gtk? ( =x11-libs/gtk+-1.2* )
+ =dev-libs/glib-1.2*
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ ruby? ( dev-lang/ruby )
+ mozilla? ( net-www/mozilla )"
+
+src_unpack() {
+ kde_src_unpack
+
+ if ! use mozilla ; then
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ cd ${S}/xparts
+ cp Makefile.am Makefile.am.orig
+ sed -e 's:mozilla::' Makefile.am.orig > Makefile.am
+ fi
+
+ cd ${S} && aclocal
+}
+
+src_compile() {
+ use python || myconf="$myconf --without-python"
+ use java && myconf="$myconf --with-java=`java-config --jdk-home`" || myconf="$myconf --without-java"
+ use ruby || myconf="$myconf --without-ruby"
+
+ # obj bindings are officially broken
+ #myconf="$myconf --enable-objc"
+
+ # we need to have csant (from pnet, from portable.NET) in portage for qtsharp
+ export DO_NOT_COMPILE="$DO_NOT_COMPILE qtsharp"
+
+ export LIBPYTHON="`python-config`"
+
+ # fix bug #14756 fex. Doesn't compile well with -j2.
+ export MAKEOPTS="$MAKEOPTS -j1"
+
+ use hppa && append-flags -ffunction-sections
+
+ kde_src_compile
+}