summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-28 17:53:18 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-28 17:53:18 +0000
commitea8368b179317a9cbab37aa7de27b4e5fc3c9374 (patch)
tree382e3e9893954faf5ed63ff885d085add31d6a5a /media-gfx/gphoto
parentRDEPEND update (diff)
downloadhistorical-ea8368b179317a9cbab37aa7de27b4e5fc3c9374.tar.gz
historical-ea8368b179317a9cbab37aa7de27b4e5fc3c9374.tar.bz2
historical-ea8368b179317a9cbab37aa7de27b4e5fc3c9374.zip
new version, few fixes
Diffstat (limited to 'media-gfx/gphoto')
-rw-r--r--media-gfx/gphoto/files/digest-gphoto-2.0_beta21
-rw-r--r--media-gfx/gphoto/gphoto-2.0_beta2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/gphoto/files/digest-gphoto-2.0_beta2 b/media-gfx/gphoto/files/digest-gphoto-2.0_beta2
new file mode 100644
index 000000000000..c610785de82e
--- /dev/null
+++ b/media-gfx/gphoto/files/digest-gphoto-2.0_beta2
@@ -0,0 +1 @@
+MD5 b2895917f1a34b60d9db36cc9bf4ffd9 gphoto-2.0beta2.tar.gz 950272
diff --git a/media-gfx/gphoto/gphoto-2.0_beta2.ebuild b/media-gfx/gphoto/gphoto-2.0_beta2.ebuild
new file mode 100644
index 000000000000..c787c26c0d00
--- /dev/null
+++ b/media-gfx/gphoto/gphoto-2.0_beta2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+
+MY_P="${PN}-`echo ${PV} |sed -e 's:_::'`"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="http://www.gphoto.net/dist/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gphoto.org/"
+
+DEPEND="virtual/glibc
+ >=dev-libs/libusb-0.1.3b
+ >=dev-libs/glib-1.2.10
+ >=sys-libs/zlib-1.1.3"
+
+
+src_compile() {
+
+ # -pipe does no work
+ env CFLAGS="${CFLAGS/-pipe/}" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || die
+
+ cp libgphoto2/Makefile libgphoto2/Makefile.orig
+ sed -e 's:$(prefix)/doc/gphoto2:/usr/share/doc/${PF}:' \
+ libgphoto2/Makefile.orig >libgphoto2/Makefile
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ gphotodocdir=${D}/usr/share/doc/${PF} \
+ HTML_DIR=${D}/usr/share/doc/${PF}/sgml \
+ install || die
+
+ dodoc ChangeLog NEWS* README
+ rm -rf ${D}/usr/share/doc/${PF}/sgml/gphoto2
+}
+