summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-03 10:36:04 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-03 10:36:04 +0000
commitba019ff6c73736b5a3f20f70d22c8afdae62fc66 (patch)
tree61444a502411a5fe6189330e76ce219682a0e381 /net-im/ohphone
parentnew command line based video conference (diff)
downloadhistorical-ba019ff6c73736b5a3f20f70d22c8afdae62fc66.tar.gz
historical-ba019ff6c73736b5a3f20f70d22c8afdae62fc66.tar.bz2
historical-ba019ff6c73736b5a3f20f70d22c8afdae62fc66.zip
new command line based video conference
Diffstat (limited to 'net-im/ohphone')
-rw-r--r--net-im/ohphone/Manifest4
-rw-r--r--net-im/ohphone/files/digest-ohphone-1.4.11
-rw-r--r--net-im/ohphone/metadata.xml6
-rw-r--r--net-im/ohphone/ohphone-1.4.1.ebuild36
4 files changed, 46 insertions, 1 deletions
diff --git a/net-im/ohphone/Manifest b/net-im/ohphone/Manifest
index 8d0560dbf36f..bdcbf03ce30b 100644
--- a/net-im/ohphone/Manifest
+++ b/net-im/ohphone/Manifest
@@ -1,2 +1,4 @@
-MD5 a211d73040cb8e68616e2f7dafb3a224 ohphone-1.4.1.ebuild 814
+MD5 7ac6272351608f61ad615ed889b4a2ad ChangeLog 377
+MD5 8f906ffe0aa837e5e26fe03af3043461 metadata.xml 219
+MD5 f17447491934c080279f50c41e3fd673 ohphone-1.4.1.ebuild 821
MD5 eb00a184805b4c495b46976ce6ccfbbf files/digest-ohphone-1.4.1 64
diff --git a/net-im/ohphone/files/digest-ohphone-1.4.1 b/net-im/ohphone/files/digest-ohphone-1.4.1
new file mode 100644
index 000000000000..e5214e0aca56
--- /dev/null
+++ b/net-im/ohphone/files/digest-ohphone-1.4.1
@@ -0,0 +1 @@
+MD5 f5b975db51589e2ed741367e20f75ed0 ohphone_1.4.1.tar.gz 77085
diff --git a/net-im/ohphone/metadata.xml b/net-im/ohphone/metadata.xml
new file mode 100644
index 000000000000..76b9f6f406d5
--- /dev/null
+++ b/net-im/ohphone/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>liquidx@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-im/ohphone/ohphone-1.4.1.ebuild b/net-im/ohphone/ohphone-1.4.1.ebuild
new file mode 100644
index 000000000000..5fda2b27719c
--- /dev/null
+++ b/net-im/ohphone/ohphone-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ohphone/ohphone-1.4.1.ebuild,v 1.1 2003/09/03 10:35:59 liquidx Exp $
+
+DESCRIPTION="Command line H.323 client"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=net-libs/openh323-1.12
+ >=dev-libs/pwlib-1.5.0"
+
+src_compile() {
+ cd ${WORKDIR}/${PN}
+ emake \
+ OPENH323DIR=/usr/share/openh323 \
+ PREFIX=/usr \
+ PWLIBDIR=/usr/share/pwlib \
+ PW_LIBDIR=/usr/lib \
+ OH323_LIBDIR=/usr/lib \
+ opt man || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ doman ohphone.1
+
+ # fill in for other archs
+ if [ ${ARCH} = "x86" ]; then
+ dobin obj_linux_x86_r/ohphone
+ fi
+}