summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-04-23 13:19:57 +0000
committerWout Mertens <wmertens@gentoo.org>2003-04-23 13:19:57 +0000
commitd575a889d8af3f6bb6cc208ab65a7892a242f97a (patch)
treec7eb51d5c6a7797a80d68806054caff1fb8aab1c /net-misc/fsh
parentnow really disabling it *duh* (diff)
downloadhistorical-d575a889d8af3f6bb6cc208ab65a7892a242f97a.tar.gz
historical-d575a889d8af3f6bb6cc208ab65a7892a242f97a.tar.bz2
historical-d575a889d8af3f6bb6cc208ab65a7892a242f97a.zip
fcpwrap bug fix
Diffstat (limited to 'net-misc/fsh')
-rw-r--r--net-misc/fsh/ChangeLog8
-rw-r--r--net-misc/fsh/files/digest-fsh-1.2-r11
-rw-r--r--net-misc/fsh/files/fsh-1.2-fcpwrap.patch17
-rw-r--r--net-misc/fsh/fsh-1.2-r1.ebuild32
4 files changed, 57 insertions, 1 deletions
diff --git a/net-misc/fsh/ChangeLog b/net-misc/fsh/ChangeLog
index e77a45f22731..b56151e40493 100644
--- a/net-misc/fsh/ChangeLog
+++ b/net-misc/fsh/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-misc/fsh
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/fsh/ChangeLog,v 1.2 2003/02/12 08:22:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fsh/ChangeLog,v 1.3 2003/04/23 13:19:57 wmertens Exp $
+*fsh-1.2-r1 (23 Apr 2003)
+
+ 23 Apr 2003; Wout Mertens <wmertens@gentoo.org>
+ fsh-1.2-r1.ebuild files/fsh-1.2-fcpwrap.patch:
+ Fixed bug where fcp user@host would fail. Reported upstream.
+
*fsh-1.2 (01 Oct 2002)
01 Oct 2002; Daniel Robbins <drobbins@gentoo.org>: Initial package.
diff --git a/net-misc/fsh/files/digest-fsh-1.2-r1 b/net-misc/fsh/files/digest-fsh-1.2-r1
new file mode 100644
index 000000000000..1b2164e12be6
--- /dev/null
+++ b/net-misc/fsh/files/digest-fsh-1.2-r1
@@ -0,0 +1 @@
+MD5 74d7fc65044d1c9c27c6e9edbbde9c68 fsh-1.2.tar.gz 152374
diff --git a/net-misc/fsh/files/fsh-1.2-fcpwrap.patch b/net-misc/fsh/files/fsh-1.2-fcpwrap.patch
new file mode 100644
index 000000000000..4fdc168d25c0
--- /dev/null
+++ b/net-misc/fsh/files/fsh-1.2-fcpwrap.patch
@@ -0,0 +1,17 @@
+--- fsh-1.2-orig/fcpwrap.c 2000-12-03 20:12:58.000000000 +0100
++++ fsh-1.2/fcpwrap.c 2003-04-23 14:56:13.000000000 +0200
+@@ -43,8 +43,12 @@
+ break;
+ if (argv [i][1] == 'l') /* fsh login flag? */
+ {
+- login = argv [++i];
+- continue;
++ if (argv [i][2]) {
++ login = argv[i] + 2;
++ } else {
++ login = argv [++i];
++ }
++ continue;
+ }
+ if (strchr (args, argv [i][1]) && argv[i][2] == '\0')
+ i++; /* Flag with an argument. */
diff --git a/net-misc/fsh/fsh-1.2-r1.ebuild b/net-misc/fsh/fsh-1.2-r1.ebuild
new file mode 100644
index 000000000000..cc9fa6c729db
--- /dev/null
+++ b/net-misc/fsh/fsh-1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fsh/fsh-1.2-r1.ebuild,v 1.1 2003/04/23 13:19:57 wmertens Exp $
+
+inherit eutils
+
+DESCRIPTION="System to allow fast-reuse of a ssh secure tunnel to avoid connection lag"
+HOMEPAGE="http://www.lysator.liu.se/fsh/"
+SRC_URI="http://www.lysator.liu.se/fsh/${P}.tar.gz"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+DEPEND="net-misc/openssh dev-lang/python"
+RDEPEND="$DEPEND"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix scp invocation parsing when user@host is used
+ epatch ${FILESDIR}/${P}-fcpwrap.patch
+}
+
+src_compile() {
+ ./configure --prefix=/usr --infodir=/usr/share/info
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* THANKS TODO
+}