summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-10-18 18:59:42 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-10-18 18:59:42 +0000
commit650d1dd0b45e55aec6537dee23f7637ef011d0d3 (patch)
tree34ac4b7d93bc6a08f551e248fefe9af19386a14a /net-misc/radvd
parentsome more minor explanations (diff)
downloadhistorical-650d1dd0b45e55aec6537dee23f7637ef011d0d3.tar.gz
historical-650d1dd0b45e55aec6537dee23f7637ef011d0d3.tar.bz2
historical-650d1dd0b45e55aec6537dee23f7637ef011d0d3.zip
initial import, ebuild by ace@sannes.org
Diffstat (limited to 'net-misc/radvd')
-rw-r--r--net-misc/radvd/ChangeLog13
-rw-r--r--net-misc/radvd/files/digest-radvd-0.7.11
-rw-r--r--net-misc/radvd/files/radvd20
-rw-r--r--net-misc/radvd/radvd-0.7.1.ebuild58
4 files changed, 92 insertions, 0 deletions
diff --git a/net-misc/radvd/ChangeLog b/net-misc/radvd/ChangeLog
new file mode 100644
index 000000000000..d9deb5decbc7
--- /dev/null
+++ b/net-misc/radvd/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-misc/radvd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.1 2002/10/18 18:59:40 hannes Exp $
+
+*radvd-0.7.1 (18th July 2002)
+
+ 18 Oct 2002; Hannes Mehnert <hannes@gentoo.org> ChangeLog, radvd-0.7.1.ebuild:
+ Initial import.
+ ebuild submitted by Asbjorn Sannes <ace@sannes.org>
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way.
+
diff --git a/net-misc/radvd/files/digest-radvd-0.7.1 b/net-misc/radvd/files/digest-radvd-0.7.1
new file mode 100644
index 000000000000..fb5df66e6833
--- /dev/null
+++ b/net-misc/radvd/files/digest-radvd-0.7.1
@@ -0,0 +1 @@
+MD5 5f0ae96490eab23ae926f9ee209c1e8b radvd-0.7.1.tar.gz 114333
diff --git a/net-misc/radvd/files/radvd b/net-misc/radvd/files/radvd
new file mode 100644
index 000000000000..7067ab1b1fa0
--- /dev/null
+++ b/net-misc/radvd/files/radvd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/files/radvd,v 1.1 2002/10/18 18:59:42 hannes Exp $
+
+depend () {
+ need net
+}
+
+start () {
+ ebegin "Starting radvd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/radvd -- -u radvd -p /var/run/radvd/radvd.pid
+ eend
+}
+
+stop() {
+ ebegin "Stopping radvd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/radvd/radvd.pid
+ eend
+}
diff --git a/net-misc/radvd/radvd-0.7.1.ebuild b/net-misc/radvd/radvd-0.7.1.ebuild
new file mode 100644
index 000000000000..17d0e82d1dd1
--- /dev/null
+++ b/net-misc/radvd/radvd-0.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.1.ebuild,v 1.1 2002/10/18 18:59:40 hannes Exp $
+
+IUSE=""
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon (radvd)"
+HOMEPAGE="http://v6web.litech.org/radvd/"
+SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
+DEPEND="virtual/glibc
+ virtual/kernel"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+pkg_preinst() {
+ if ! groupmod radvd; then
+ groupadd -g 75 radvd || die "problem adding group radvd"
+ fi
+
+ usermod radvd &>/dev/null
+ if [ $? != 2 ]; then
+ useradd -u 75 -g radvd -s /bin/false -d / -c "Router Advertisement Daemon (radvd)" radvd
+ assert "problem adding user radvd"
+ fi
+}
+
+src_compile() {
+ econf --libexecdir=/usr/lib/radvd \
+ --with-pidfile=/var/run/radvd/radvd.pid \
+ --sysconfdir=/etc/radvd || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYRIGHT INTRO.html README TODO
+
+ insinto /etc/radvd
+ doins radvd.conf.example
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/radvd
+
+ mkdir -p ${D}/var/run/radvd
+ fowners radvd.radvd /var/run/radvd
+ fperms 755 /var/run/radvd
+}
+
+pkg_postinst () {
+ einfo To make it work you have to configure /etc/radvd/radvd.conf and put
+ einfo the line net.ipv6.conf.all.forwarding = 1 in sysctl.conf or just run
+ einfo sysctl -w net.ipv6.conf.all.forwarding=1 in your firewallscripts before
+ einfo starting radvd.
+ einfo
+ einfo echo 1 \> /proc/sys/net/ipv6/conf/all/forwarding should also work.
+ einfo
+ einfo "rc-update add radvd default" should make it start at boottime.
+}