summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-21 20:27:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-21 20:27:52 +0000
commit052e53594465a28574839f7b2e7ab4c06a06bb58 (patch)
tree535b453ba5787af950108ea2a8df00ce73989a9b /net-p2p/deluge/files
parentVersion bump, drop old (diff)
downloadhistorical-052e53594465a28574839f7b2e7ab4c06a06bb58.tar.gz
historical-052e53594465a28574839f7b2e7ab4c06a06bb58.tar.bz2
historical-052e53594465a28574839f7b2e7ab4c06a06bb58.zip
Prevent deluge from downloading rb_libtorrent from svn if the system one is broken. Thanks to Arfrever
Package-Manager: portage-2.1.11.37/cvs/Linux x86_64 Manifest-Sign-Key: 0xB4AFF2C2
Diffstat (limited to 'net-p2p/deluge/files')
-rw-r--r--net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch b/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
new file mode 100644
index 000000000000..235b7f7c2438
--- /dev/null
+++ b/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
@@ -0,0 +1,42 @@
+--- setup.py
++++ setup.py
+@@ -205,38 +205,7 @@
+
+ _ext_modules = []
+
+-# Check for a system libtorrent and if found, then do not build the libtorrent extension
+-build_libtorrent = True
+-try:
+- from deluge._libtorrent import lt
+-except ImportError:
+- build_libtorrent = True
+-else:
+- build_libtorrent = False
+-
+-if build_libtorrent:
+- got_libtorrent = False
+- if not os.path.exists("libtorrent"):
+- import subprocess
+- if subprocess.call(['./get_libtorrent.sh']) > 0:
+- got_libtorrent = False
+- else:
+- got_libtorrent = True
+- else:
+- got_libtorrent = True
+-
+- if got_libtorrent:
+- # There isn't a system libtorrent library, so let's build the one included with deluge
+- libtorrent = Extension(
+- 'libtorrent',
+- extra_compile_args = _extra_compile_args,
+- include_dirs = _include_dirs,
+- libraries = _libraries,
+- library_dirs = _library_dirs,
+- sources = _sources
+- )
+-
+- _ext_modules = [libtorrent]
++import deluge._libtorrent
+
+ desktop_data = 'deluge/data/share/applications/deluge.desktop'
+