summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-11-26 20:11:17 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-11-26 20:11:17 +0000
commit215ee20f758e8e37b82381ef4460b99acf195089 (patch)
treefe34cfca2609e8598ffab3db11ddcdf803076fdc /net-p2p
parentAdd patch upstream to fix handling of --devices and fifos #113640 by Ingo van... (diff)
downloadhistorical-215ee20f758e8e37b82381ef4460b99acf195089.tar.gz
historical-215ee20f758e8e37b82381ef4460b99acf195089.tar.bz2
historical-215ee20f758e8e37b82381ef4460b99acf195089.zip
Added support for specifying options to the java binary in ~/.Azureus/gentoo.config. This makes it possible to run the vm in for example server mode. Resolves bug #75090.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog8
-rw-r--r--net-p2p/azureus/Manifest10
-rw-r--r--net-p2p/azureus/files/azureus-gentoo-2.3.0.6.sh5
3 files changed, 16 insertions, 7 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index a0406ede41d0..1ab9faf8401a 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.10 2005/11/26 17:32:38 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.11 2005/11/26 20:11:17 betelgeuse Exp $
+
+ 26 Nov 2005; Petteri Räty <betelgeuse@gentoo.org>
+ files/azureus-gentoo-2.3.0.6.sh:
+ Added support for specifying options to the java binary in
+ ~/.Azureus/gentoo.config. This makes it possible to run the vm in for
+ example server mode. Resolves bug #75090.
*azureus-2.3.0.6 (26 Nov 2005)
diff --git a/net-p2p/azureus/Manifest b/net-p2p/azureus/Manifest
index 92cd579a7ca3..d15309563c64 100644
--- a/net-p2p/azureus/Manifest
+++ b/net-p2p/azureus/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 34ea6307f4838a4a2d8e66d994a0a69f ChangeLog 1834
+MD5 260bb6c397e165dc5b872fd342ed9342 ChangeLog 2100
MD5 ff3e702ff946e17b534a1a0971cab592 azureus-2.2.0.0-r1.ebuild 2345
MD5 0aee5632d7755d629ae59035e6e59f92 azureus-2.3.0.4.ebuild 2603
MD5 d6e296fcd97d1e4b84db63ef7d1f61e9 azureus-2.3.0.6.ebuild 3522
MD5 21218e1a7c134f02c8e42bcb63375e74 files/SWTThread.java 2549
MD5 e3cc00baa30d499993d4f65e56ad03bc files/UpdaterPatcher.java 2523
MD5 6d60bd5e1461cf5f8bc467794e6a1827 files/azureus-gentoo-2.3.0.4.sh 1008
-MD5 d5fd79649f95df6df10bcafbca2cc927 files/azureus-gentoo-2.3.0.6.sh 1023
+MD5 73bde66af28bc11215724d5edc2a92e4 files/azureus-gentoo-2.3.0.6.sh 1102
MD5 77d299aef0633c501b998f3ec0c1f0c9 files/azureus-gentoo.sh 1010
MD5 70c17db47c9a596929112714f82ac010 files/azureus.desktop 153
MD5 2d3136c60488dd51bef012cbcb59201b files/azureus.png 743
@@ -20,7 +20,7 @@ MD5 a63336d02253ae5fe2ad69f813bdd7d8 metadata.xml 329
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDiJxEQiJ/wx066S4RAhTuAJ9FgZRnzfz8jWVCCOQVrBxEOAWNkACeL9a8
-s2slRfTVN3aJN5RyUlHPKFM=
-=3tfU
+iD8DBQFDiMFzQiJ/wx066S4RAhySAJ98TjC4Ee/6wweRbnS8R+8zYkHQRACeKLzc
+xC8rchm3xbOce3BzHgvvbAE=
+=pYWR
-----END PGP SIGNATURE-----
diff --git a/net-p2p/azureus/files/azureus-gentoo-2.3.0.6.sh b/net-p2p/azureus/files/azureus-gentoo-2.3.0.6.sh
index 9ccaed385d75..c10e186a743c 100644
--- a/net-p2p/azureus/files/azureus-gentoo-2.3.0.6.sh
+++ b/net-p2p/azureus/files/azureus-gentoo-2.3.0.6.sh
@@ -32,6 +32,9 @@ else
# When selecting just 1, use '--ui=<ui>'
# When selecting multiple, use '--uis=<ui>,<ui>'
UI_OPTIONS="--ui=swt"
+
+# Options you want to pass to the java binary
+JAVA_OPTIONS=""
END
fi
@@ -40,4 +43,4 @@ cd ${dotazudir}
CLASSPATH=$(java-config -p junit,log4j,commons-cli-1,swt-3,azureus)
java -cp $CLASSPATH -Djava.library.path=$(java-config -i swt-3) \
- org.gudy.azureus2.ui.swt.Main "${@}"
+ ${JAVA_OPTIONS} org.gudy.azureus2.ui.swt.Main "${@}"