summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
commit7eba6dba58d33500e18b9d0b1e2362b757a76459 (patch)
treeadd73700f1963ae7c1cd34a7f1b2bea569ceb44b /net-www/mod_authenticache
parentupdated layout (diff)
downloadhistorical-7eba6dba58d33500e18b9d0b1e2362b757a76459.tar.gz
historical-7eba6dba58d33500e18b9d0b1e2362b757a76459.tar.bz2
historical-7eba6dba58d33500e18b9d0b1e2362b757a76459.zip
new Apache2 module
Diffstat (limited to 'net-www/mod_authenticache')
-rw-r--r--net-www/mod_authenticache/ChangeLog8
-rw-r--r--net-www/mod_authenticache/files/28_mod_authenticache.conf31
-rw-r--r--net-www/mod_authenticache/files/digest-mod_authenticache-2.0.61
-rw-r--r--net-www/mod_authenticache/files/dot-htaccess8
-rw-r--r--net-www/mod_authenticache/files/dot-htpasswd1
-rw-r--r--net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild32
6 files changed, 81 insertions, 0 deletions
diff --git a/net-www/mod_authenticache/ChangeLog b/net-www/mod_authenticache/ChangeLog
new file mode 100644
index 000000000000..fce7b0903282
--- /dev/null
+++ b/net-www/mod_authenticache/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_authenticache
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_authenticache/ChangeLog,v 1.1 2002/11/28 20:34:47 woodchip Exp $
+
+*mod_authenticache-2.0.6 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_authenticache/files/28_mod_authenticache.conf b/net-www/mod_authenticache/files/28_mod_authenticache.conf
new file mode 100644
index 000000000000..b81a1719965f
--- /dev/null
+++ b/net-www/mod_authenticache/files/28_mod_authenticache.conf
@@ -0,0 +1,31 @@
+<IfDefine AUTHENTICACHE>
+ <IfModule !mod_authenticache.c>
+ LoadModule authenticache_module extramodules/mod_authenticache.so
+ </IfModule>
+</IfDefine>
+
+# NOTE!
+# You should login as "test" with the "test" password (without the
+# quotes) to use the example below. You also should enable cookies
+# in your web browser.
+
+<IfModule mod_authenticache.c>
+
+AccessFileName .htaccess
+<Directory _REPLACE_ME_>
+
+ Authenticache On
+ AuthenticacheAuthoritative Off
+ AuthenticacheTTL 600
+ AuthenticacheMaxTTL 3600
+ AuthenticacheTicketName AuthentiCache
+ AuthenticacheTicketPath /
+ AuthenticacheVerifyIP On
+
+ Options None
+ AllowOverride All
+
+</Directory>
+
+</IfModule>
+
diff --git a/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6 b/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6
new file mode 100644
index 000000000000..b1f2a0051eb3
--- /dev/null
+++ b/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6
@@ -0,0 +1 @@
+MD5 047015199037e9e434e4511bbdfed77b mod_authenticache-2.0.6.tar.bz2 6175
diff --git a/net-www/mod_authenticache/files/dot-htaccess b/net-www/mod_authenticache/files/dot-htaccess
new file mode 100644
index 000000000000..a41d2bfc1100
--- /dev/null
+++ b/net-www/mod_authenticache/files/dot-htaccess
@@ -0,0 +1,8 @@
+AuthUserFile _REPLACE_ME_.htpasswd
+AuthGroupFile /dev/null
+AuthName "Testing mod_authenticache, use test/test as l/p."
+AuthType Basic
+
+<Limit GET>
+ require user test
+</Limit>
diff --git a/net-www/mod_authenticache/files/dot-htpasswd b/net-www/mod_authenticache/files/dot-htpasswd
new file mode 100644
index 000000000000..32ed4cf89530
--- /dev/null
+++ b/net-www/mod_authenticache/files/dot-htpasswd
@@ -0,0 +1 @@
+test:72w6mcwTjDA8A
diff --git a/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
new file mode 100644
index 000000000000..588e76180736
--- /dev/null
+++ b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild,v 1.1 2002/11/28 20:34:47 woodchip Exp $
+
+DESCRIPTION="A generic Apache2 credential caching module"
+HOMEPAGE="http://original.killa.net/infosec/mod_authenticache/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://original.killa.net/infosec/${PN}/${P}.tar.bz2"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ #fix version string
+ perl -pi -e "s|^#define VERSION .*|#define VERSION \"${PV}\"|g" \
+ defines.h
+ apxs2 -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/28_mod_authenticache.conf
+ dodoc ${FILESDIR}/28_mod_authenticache.conf
+ newdoc ${FILESDIR}/dot-htaccess .htaccess
+ newdoc ${FILESDIR}/dot-htpasswd .htpasswd
+}