summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-04 18:36:31 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-04 18:36:31 +0000
commit935f051483c4e7afa02e13c89034d8d6984e05bf (patch)
treefa7ba4ef40bf3fd961827f98f51b7e7d99de5d50 /sys-apps/baselayout/baselayout-2.1.ebuild
parentVersion bump. (diff)
downloadhistorical-935f051483c4e7afa02e13c89034d8d6984e05bf.tar.gz
historical-935f051483c4e7afa02e13c89034d8d6984e05bf.tar.bz2
historical-935f051483c4e7afa02e13c89034d8d6984e05bf.zip
Try to make error output a little more understandable #385625 by Paul Varner.
Package-Manager: portage-2.2.0_alpha59/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/baselayout/baselayout-2.1.ebuild')
-rw-r--r--sys-apps/baselayout/baselayout-2.1.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/sys-apps/baselayout/baselayout-2.1.ebuild b/sys-apps/baselayout/baselayout-2.1.ebuild
index eba860455d7c..9b157fa7d29a 100644
--- a/sys-apps/baselayout/baselayout-2.1.ebuild
+++ b/sys-apps/baselayout/baselayout-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.1.ebuild,v 1.1 2011/10/03 03:59:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.1.ebuild,v 1.2 2011/10/04 18:36:31 vapier Exp $
inherit eutils multilib
@@ -21,6 +21,17 @@ pkg_setup() {
}
# Create our multilib dirs - the Makefile has no knowledge of this
+multilib_warn() {
+ local syms=$1 dirs=$2 def_libdir=$3
+
+ [ -z "${syms}${dirs}" ] && return
+
+ ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB}, so that means"
+ if [ -z "${syms}" ] ; then
+ ewarn "you need to have these paths as symlinks to ${def_libdir}:"
+ ewarn "$1"
+ fi
+}
multilib_layout() {
local libdir libdirs=$(get_all_libdirs) def_libdir=$(get_abi_LIBDIR $DEFAULT_ABI)
: ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
@@ -38,16 +49,13 @@ multilib_layout() {
fi
done
done
- if [ -n "${syms}" ] ; then
- ewarn "Based on your profile, these paths should be directories:"
- ewarn "${syms}"
- ewarn "Failure to fix this may result in a broken system."
- echo
- fi
- if [ -n "${dirs}" ] ; then
- ewarn "Based on your profile, these paths should be symlinks:"
- ewarn "${dirs}"
- ewarn "Failure to fix this may result in a broken system."
+ if [ -n "${syms}${dirs}" ] ; then
+ ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB:-no}, so that means you need to"
+ ewarn "have these paths configured as follows:"
+ [ -n "${dirs}" ] && ewarn "symlinks to '${def_libdir}':${dirs}"
+ [ -n "${syms}" ] && ewarn "directories:${syms}"
+ ewarn "The ebuild will attempt to fix these, but only for trivial conversions."
+ ewarn "If things fail, you will need to manually create/move the directories."
echo
fi