summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-05-20 04:11:03 +0000
committerMike Frysinger <vapier@gentoo.org>2010-05-20 04:11:03 +0000
commitbfebdb7cfbc8b900c4defc30263bcacaa8b7fd84 (patch)
tree20263bcdefcf0e2c6443fa1d9f17a08618c0e049 /sys-apps/gawk/gawk-3.1.8.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-bfebdb7cfbc8b900c4defc30263bcacaa8b7fd84.tar.gz
historical-bfebdb7cfbc8b900c4defc30263bcacaa8b7fd84.tar.bz2
historical-bfebdb7cfbc8b900c4defc30263bcacaa8b7fd84.zip
Version bump #319763 by Samuli Suominen.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/gawk/gawk-3.1.8.ebuild')
-rw-r--r--sys-apps/gawk/gawk-3.1.8.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sys-apps/gawk/gawk-3.1.8.ebuild b/sys-apps/gawk/gawk-3.1.8.ebuild
new file mode 100644
index 000000000000..eb0520df9450
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.8.ebuild,v 1.1 2010/05/20 04:11:03 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+SFFS=${WORKDIR}/filefuncs
+
+src_unpack() {
+ unpack ${A}
+
+ # Copy filefuncs module's source over ...
+ cp -r "${FILESDIR}"/filefuncs "${SFFS}" || die "cp failed"
+}
+
+src_prepare() {
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_enable nls) \
+ --enable-switch
+}
+
+src_compile() {
+ emake || die
+ emake -C "${SFFS}" CC=$(tc-getCC) || die "filefuncs emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ emake -C "${SFFS}" LIBDIR="$(get_libdir)" install || die
+
+ # Keep important gawk in /bin
+ if use userland_GNU ; then
+ dodir /bin
+ mv "${D}"/usr/bin/gawk "${D}"/bin/ || die
+ dosym /bin/gawk /usr/bin/gawk
+
+ # Provide canonical `awk`
+ dosym gawk /bin/awk
+ dosym gawk /usr/bin/awk
+ dosym gawk.1 /usr/share/man/man1/awk.1
+ fi
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ # We do not want 'acconfig.h' in there ...
+ rm -f "${D}"/usr/include/awk/acconfig.h
+
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README README_d/*.*
+ for x in */ChangeLog ; do
+ newdoc ${x} ${x##*/}.${x%%/*}
+ done
+}