summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-25 16:10:14 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-25 16:10:14 +0000
commit0bc4d447b61e4fd497319dbe79896e1a678bb597 (patch)
treef52bc6ab95e97e4e0cdb8ade9f5dcf8098d19b2b /sys-apps/gawk
parentAdd fix from upstream for CVE-2007-3108 #188799. (diff)
downloadhistorical-0bc4d447b61e4fd497319dbe79896e1a678bb597.tar.gz
historical-0bc4d447b61e4fd497319dbe79896e1a678bb597.tar.bz2
historical-0bc4d447b61e4fd497319dbe79896e1a678bb597.zip
old
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.5-r23
-rw-r--r--sys-apps/gawk/gawk-3.1.5-r2.ebuild113
2 files changed, 0 insertions, 116 deletions
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.5-r2 b/sys-apps/gawk/files/digest-gawk-3.1.5-r2
deleted file mode 100644
index 9ac602be41d5..000000000000
--- a/sys-apps/gawk/files/digest-gawk-3.1.5-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4760325489479cac17fe0114b8f62f30 gawk-3.1.5.tar.gz 2310919
-RMD160 8d875f4ea9e9ef5c932468cf43c691f6e082b197 gawk-3.1.5.tar.gz 2310919
-SHA256 463dcb9d0ca398b1d4f5a332f6cd9cec56441265fca616f2ea1b44d459e9f0f8 gawk-3.1.5.tar.gz 2310919
diff --git a/sys-apps/gawk/gawk-3.1.5-r2.ebuild b/sys-apps/gawk/gawk-3.1.5-r2.ebuild
deleted file mode 100644
index 2ec4d6f85a33..000000000000
--- a/sys-apps/gawk/gawk-3.1.5-r2.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5-r2.ebuild,v 1.16 2007/01/26 08:42:19 vapier Exp $
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="GNU awk pattern-matching language"
-HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
-SRC_URI="mirror://gnu/gawk/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-SFFS=${WORKDIR}/filefuncs
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- # Copy filefuncs module's source over ...
- cp -r "${FILESDIR}"/filefuncs "${SFFS}" || die "cp failed"
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-core.patch
- epatch "${FILESDIR}"/${P}-gcc4.patch
- epatch "${FILESDIR}"/${P}-utf-8-strcat.patch
- epatch "${FILESDIR}"/${P}-autotools-crap.patch #139397
- # Patches from Fedora
- epatch "${FILESDIR}"/${PN}-3.1.3-getpgrp_void.patch
- epatch "${FILESDIR}"/${P}-fieldwidths.patch #127163
- epatch "${FILESDIR}"/${P}-binmode.patch
- epatch "${FILESDIR}"/${P}-num2str.patch
- epatch "${FILESDIR}"/${P}-internal.patch
- epatch "${FILESDIR}"/${P}-numflags.patch
- epatch "${FILESDIR}"/${P}-syntaxerror.patch
- # support for dec compiler.
- [[ $(tc-getCC) == "ccc" ]] && epatch "${FILESDIR}"/${PN}-3.1.2-dec-alpha-compiler.diff
-}
-
-src_compile() {
- econf \
- --bindir=/bin \
- --libexec='$(libdir)/misc' \
- $(use_enable nls) \
- --enable-switch \
- || die
- emake || die "emake failed"
-
- cd "${SFFS}"
- emake CC=$(tc-getCC) || die "filefuncs emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "install failed"
- cd "${SFFS}"
- make LIBDIR="$(get_libdir)" install || die "filefuncs install failed"
-
- dodir /usr/bin
- # In some rare cases, (p)gawk gets installed as (p)gawk- and not
- # (p)gawk-${PV} ... Also make sure that /bin/(p)gawk is a symlink
- # to /bin/(p)gawk-${PV}.
- local binpath x
- for x in gawk pgawk igawk ; do
- [[ ${x} == "gawk" ]] \
- && binpath="/bin" \
- || binpath="/usr/bin"
-
- if [[ -f ${D}/bin/${x} && ! -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f "${D}"/bin/${x} "${D}"/${binpath}/${x}-${PV}
- elif [[ -f ${D}/bin/${x}- && ! -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f "${D}"/bin/${x}- "${D}"/${binpath}/${x}-${PV}
- elif [[ ${binpath} == "/usr/bin" && -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f "${D}"/bin/${x}-${PV} "${D}"/${binpath}/${x}-${PV}
- fi
-
- rm -f "${D}"/bin/${x}
- dosym ${x}-${PV} ${binpath}/${x}
- [[ ${binpath} == "/usr/bin" ]] && dosym /usr/bin/${x}-${PV} /bin/${x}
- done
-
- rm -f "${D}"/bin/awk
- dodir /usr/bin
- # Compat symlinks
- dosym /bin/gawk-${PV} /usr/bin/gawk
- dosym gawk-${PV} /bin/awk
- dosym /bin/gawk-${PV} /usr/bin/awk
- [[ ${USERLAND} != "GNU" ]] && rm -f "${D}"/{,usr/}bin/awk{,-${PV}}
-
- # Install headers
- insinto /usr/include/awk
- doins "${S}"/*.h || die "ins headers failed"
- # We do not want 'acconfig.h' in there ...
- rm -f "${D}"/usr/include/awk/acconfig.h
-
- cd "${S}"
- rm -f "${D}"/usr/share/man/man1/pgawk.1
- dosym gawk.1 /usr/share/man/man1/pgawk.1
- [[ ${USERLAND} == "GNU" ]] && dosym gawk.1 /usr/share/man/man1/awk.1
- dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README
- docinto README_d
- dodoc README_d/*
- docinto awklib
- dodoc awklib/ChangeLog
- docinto pc
- dodoc pc/ChangeLog
- docinto posix
- dodoc posix/ChangeLog
-}