summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-14 07:00:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-14 07:00:16 +0000
commitc57993575dd8fa2fc77982dee58d739d73cdcdb8 (patch)
tree50b1667d475b4d75ee87227c75c16c8c8534a4b0 /sys-apps/hotplug
parentversion bump to most recent snapshot (diff)
downloadhistorical-c57993575dd8fa2fc77982dee58d739d73cdcdb8.tar.gz
historical-c57993575dd8fa2fc77982dee58d739d73cdcdb8.tar.bz2
historical-c57993575dd8fa2fc77982dee58d739d73cdcdb8.zip
version bump to most recent snapshot
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/Manifest2
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-200308052
-rw-r--r--sys-apps/hotplug/hotplug-20030805.ebuild57
3 files changed, 60 insertions, 1 deletions
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index d054f4dc584e..a5446955592d 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,5 +1,5 @@
MD5 5ab9b61479b8fafefcaca30dbdbb314d hotplug-20020826-r2.ebuild 1563
-MD5 7ab51e654df013a89c09e8fce0c92db9 hotplug-20030805.ebuild 1491
+MD5 95eed4ffc6aac22db5d1030f2d528e2e hotplug-20030805.ebuild 1530
MD5 8adbe30df2fad3fcdc443742156ddce5 hotplug-20030501-r2.ebuild 1517
MD5 35af032ade36a7e7d53c53f3819659d7 ChangeLog 3636
MD5 0e5a1a005fcfa0e242be02e9ef99de7a files/digest-hotplug-20020826-r2 224
diff --git a/sys-apps/hotplug/files/digest-hotplug-20030805 b/sys-apps/hotplug/files/digest-hotplug-20030805
new file mode 100644
index 000000000000..faa1d90068fa
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20030805
@@ -0,0 +1,2 @@
+MD5 200eef33ddfcee9c023a3a7797ac6919 hotplug-2003_08_05.tar.gz 42537
+MD5 a0db235527f911f91473e04f752fbffe hotplug-20030805-gentoo-patches.tar.bz2 1991
diff --git a/sys-apps/hotplug/hotplug-20030805.ebuild b/sys-apps/hotplug/hotplug-20030805.ebuild
new file mode 100644
index 000000000000..bb63b797b691
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20030805.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20030805.ebuild,v 1.1 2003/09/14 07:00:11 seemant Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~hppa ~sparc ~alpha ~mips ~arm"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/hotplug-patches
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+