summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-01 21:34:11 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-01 21:34:11 +0000
commit91c58f2822670c0abda8c07b6e31fca74c65a00a (patch)
tree78644ed19e58960eaf5ed20b437ee13d286bdac5 /sys-apps
parentadd $LICENSE to all the kde apps (diff)
downloadhistorical-91c58f2822670c0abda8c07b6e31fca74c65a00a.tar.gz
historical-91c58f2822670c0abda8c07b6e31fca74c65a00a.tar.bz2
historical-91c58f2822670c0abda8c07b6e31fca74c65a00a.zip
remove automake dep
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/ChangeLog7
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.2-r41
-rw-r--r--sys-apps/texinfo/texinfo-4.2-r4.ebuild66
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index 26b86f09f2e3..ca645b3bfa75 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/texinfo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.4 2002/06/28 01:33:48 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.5 2002/07/01 21:34:11 azarah Exp $
+
+*texinfo-4.2-r4 (1 Jul 2002)
+
+ Remove automake DEPEND, as it is not needed, and pulls in perl during
+ bootstrap.
*texinfo-4.2-r3 (27 Jun 2002)
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.2-r4 b/sys-apps/texinfo/files/digest-texinfo-4.2-r4
new file mode 100644
index 000000000000..c3b196a597a0
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.2-r4
@@ -0,0 +1 @@
+MD5 41a97498d34ddbf245df40a95977be7f texinfo-4.2.tar.gz 1666333
diff --git a/sys-apps/texinfo/texinfo-4.2-r4.ebuild b/sys-apps/texinfo/texinfo-4.2-r4.ebuild
new file mode 100644
index 000000000000..9cb618b07c35
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.2-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.2-r4.ebuild,v 1.1 2002/07/01 21:34:11 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU info program and utilities"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/texinfo/${P}.tar.gz
+ ftp://ftp.gnu.org/pub/gnu/texinfo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+if [ "`use build`" ] ; then
+ DEPEND="virtual/glibc"
+else
+ DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )"
+# >=sys-devel/automake-1.6"
+ RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+fi
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] || [ "`use build`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ export WANT_AUTOMAKE_1_6=1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ if [ "`use build`" ] ; then
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ make DESTDIR=${D} \
+ infodir=/usr/share/info \
+ install || die
+
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ cd ${D}/usr/share/info
+ mv texinfo texinfo.info
+ for i in texinfo-*
+ do
+ mv ${i} texinfo.info-${i#texinfo-*}
+ done
+ cd ${S}
+
+ dodoc AUTHORS ChangeLog COPYING INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}
+