summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-10-07 20:30:40 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-10-07 20:30:40 +0000
commitf3bdf70b3b41705ccf63188070dad9be246831fd (patch)
treebb36f8b282168c539b9660b65453722c7141a264 /www-servers
parent* nginx-0.3+ masked (diff)
downloadhistorical-f3bdf70b3b41705ccf63188070dad9be246831fd.tar.gz
historical-f3bdf70b3b41705ccf63188070dad9be246831fd.tar.bz2
historical-f3bdf70b3b41705ccf63188070dad9be246831fd.zip
* 2xBump
Package-Manager: portage-2.0.53_rc4
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/Manifest6
-rw-r--r--www-servers/nginx/files/digest-nginx-0.2.61
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.01
-rw-r--r--www-servers/nginx/nginx-0.2.6.ebuild70
-rw-r--r--www-servers/nginx/nginx-0.3.0.ebuild70
6 files changed, 155 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index fabb9739703b..33afaf84c8f7 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.47 2005/10/05 07:29:10 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.48 2005/10/07 20:30:40 voxus Exp $
+
+*nginx-0.2.6 (08 Oct 2005)
+*nginx-0.3.0 (08 Oct 2005)
+
+ 08 Oct 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.2.6.ebuild,
+ +nginx-0.3.0.ebuild:
+ Double bump.
*nginx-0.2.5 (05 Oct 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 1148428957ad..9253ea475840 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,9 +1,11 @@
-MD5 c8843b15278ee4864734b2e8d6ee106e ChangeLog 8330
+MD5 543d0ab34ee47226265b78cb36995ddc ChangeLog 8499
MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 ed882ba7b3d8655035ab7b1df383cb1e files/digest-nginx-0.2.1 63
MD5 5a800d15945631995ab77315c11b7e46 files/digest-nginx-0.2.3 63
MD5 ef1dbbfda1d3c319e8a22c89f8618241 files/digest-nginx-0.2.4 63
MD5 e9ba279cc8e53f4cfea90ff7387a059a files/digest-nginx-0.2.5 63
+MD5 86fb37c347608004443f47aabae2fec7 files/digest-nginx-0.2.6 63
+MD5 13bbb4336b126f69b9afb9873dd0af0b files/digest-nginx-0.3.0 63
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
@@ -12,3 +14,5 @@ MD5 3c18bb527b67288a5978c43962bfd4bc nginx-0.2.1.ebuild 1936
MD5 60ddd97ebfc099421ce6cd3bef5020dd nginx-0.2.3.ebuild 1936
MD5 723f51ae02e02bb74b68a7d189f1b43f nginx-0.2.4.ebuild 1936
MD5 0e57256a28ecfeb01959ca3eef2d60ab nginx-0.2.5.ebuild 1936
+MD5 21a4e670cdfbc31f938e868e7158122f nginx-0.2.6.ebuild 1936
+MD5 e616d9aca5a99523c07fe482f84a171c nginx-0.3.0.ebuild 1936
diff --git a/www-servers/nginx/files/digest-nginx-0.2.6 b/www-servers/nginx/files/digest-nginx-0.2.6
new file mode 100644
index 000000000000..2bff6f4aa55d
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.2.6
@@ -0,0 +1 @@
+MD5 8e60eb03dd75226d21068f8d98362152 nginx-0.2.6.tar.gz 329236
diff --git a/www-servers/nginx/files/digest-nginx-0.3.0 b/www-servers/nginx/files/digest-nginx-0.3.0
new file mode 100644
index 000000000000..86fd009fa74e
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.0
@@ -0,0 +1 @@
+MD5 8e30bc9053aa75b1d20a4b3552073d8a nginx-0.3.0.tar.gz 328728
diff --git a/www-servers/nginx/nginx-0.2.6.ebuild b/www-servers/nginx/nginx-0.2.6.ebuild
new file mode 100644
index 000000000000..75049816f42e
--- /dev/null
+++ b/www-servers/nginx/nginx-0.2.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.2.6.ebuild,v 1.1 2005/10/07 20:30:40 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}
diff --git a/www-servers/nginx/nginx-0.3.0.ebuild b/www-servers/nginx/nginx-0.3.0.ebuild
new file mode 100644
index 000000000000..f16be91a64a9
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.0.ebuild,v 1.1 2005/10/07 20:30:40 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}