summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-01-06 15:22:06 +0000
committerBen de Groot <yngwin@gentoo.org>2009-01-06 15:22:06 +0000
commitfc673922ce187eedc42780c54abfbc1543ee8405 (patch)
tree17b15be179dd53a2f80e1adbc523e49757b88379 /x11-libs
parentAdded patches from bug #252287 to fix compilation with gcc-4.4 (thanks to Dan... (diff)
downloadhistorical-fc673922ce187eedc42780c54abfbc1543ee8405.tar.gz
historical-fc673922ce187eedc42780c54abfbc1543ee8405.tar.bz2
historical-fc673922ce187eedc42780c54abfbc1543ee8405.zip
Clean out old ebuilds
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.27-hh7 i686
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog8
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.0.ebuild68
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.1.ebuild68
-rw-r--r--x11-libs/qt-svg/ChangeLog8
-rw-r--r--x11-libs/qt-svg/qt-svg-4.4.0.ebuild38
-rw-r--r--x11-libs/qt-svg/qt-svg-4.4.1.ebuild38
-rw-r--r--x11-libs/qt-test/ChangeLog8
-rw-r--r--x11-libs/qt-test/qt-test-4.4.0.ebuild33
-rw-r--r--x11-libs/qt-test/qt-test-4.4.1.ebuild33
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.0.ebuild31
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.1.ebuild31
12 files changed, 24 insertions, 348 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 9a66a0ab037c..897b6c8f943f 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-sql
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.17 2008/09/19 00:16:01 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.18 2009/01/06 15:13:38 yngwin Exp $
+
+ 06 Jan 2009; Ben de Groot <yngwin@gentoo.org> -qt-sql-4.4.0.ebuild,
+ -qt-sql-4.4.1.ebuild:
+ Clean out old ebuilds
*qt-sql-4.4.2 (19 Sep 2008)
diff --git a/x11-libs/qt-sql/qt-sql-4.4.0.ebuild b/x11-libs/qt-sql/qt-sql-4.4.0.ebuild
deleted file mode 100644
index 4e3fa4c28840..000000000000
--- a/x11-libs/qt-sql/qt-sql-4.4.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0.ebuild,v 1.8 2008/06/20 10:28:07 ingmar Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The SQL module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="firebird mysql odbc postgres +qt3support +sqlite"
-
-DEPEND="
- ~x11-libs/qt-core-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}
- firebird? ( dev-db/firebird )
- sqlite? ( dev-db/sqlite:3 )
- mysql? ( virtual/mysql )
- postgres? ( virtual/postgresql-base )
- odbc? ( dev-db/unixODBC )"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-pkg_setup() {
- if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
- ewarn "You need to enable at least one SQL driver. Enable at least"
- ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
- die "Enable at least one SQL driver."
- fi
-
- use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
- ~x11-libs/qt-core-${PV} qt3support"
-
- qt4-build_pkg_setup
-}
-
-src_unpack() {
- qt4-build_src_unpack
-
- sed -e '/pg_config --libs/d' -i "${S}"/configure \
- || die 'Sed to fix postgresql usage in ./configure failed.'
-}
-
-src_compile() {
- local myconf
- # Don't support sqlite2 anymore
- myconf="${myconf} -no-sql-sqlite2
- $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
- $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
- $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
- $(qt_use odbc sql-odbc plugin)
- $(qt_use qt3support)"
-
- myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
- -no-glib -no-opengl -no-svg"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-sql/qt-sql-4.4.1.ebuild b/x11-libs/qt-sql/qt-sql-4.4.1.ebuild
deleted file mode 100644
index 5557654fb366..000000000000
--- a/x11-libs/qt-sql/qt-sql-4.4.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.1.ebuild,v 1.1 2008/08/11 13:09:16 yngwin Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The SQL module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="firebird mysql odbc postgres +qt3support +sqlite"
-
-DEPEND="
- ~x11-libs/qt-core-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}
- firebird? ( dev-db/firebird )
- sqlite? ( dev-db/sqlite:3 )
- mysql? ( virtual/mysql )
- postgres? ( virtual/postgresql-base )
- odbc? ( dev-db/unixODBC )"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-pkg_setup() {
- if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
- ewarn "You need to enable at least one SQL driver. Enable at least"
- ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
- die "Enable at least one SQL driver."
- fi
-
- use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
- ~x11-libs/qt-core-${PV} qt3support"
-
- qt4-build_pkg_setup
-}
-
-src_unpack() {
- qt4-build_src_unpack
-
- sed -e '/pg_config --libs/d' -i "${S}"/configure \
- || die 'Sed to fix postgresql usage in ./configure failed.'
-}
-
-src_compile() {
- local myconf
- # Don't support sqlite2 anymore
- myconf="${myconf} -no-sql-sqlite2
- $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
- $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
- $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
- $(qt_use odbc sql-odbc plugin)
- $(qt_use qt3support)"
-
- myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
- -no-glib -no-opengl -no-svg"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 623eb32593a5..ff66df00c0e2 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-svg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.12 2008/09/19 00:16:49 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.13 2009/01/06 15:16:33 yngwin Exp $
+
+ 06 Jan 2009; Ben de Groot <yngwin@gentoo.org> -qt-svg-4.4.0.ebuild,
+ -qt-svg-4.4.1.ebuild:
+ Clean out old ebuilds
*qt-svg-4.4.2 (19 Sep 2008)
diff --git a/x11-libs/qt-svg/qt-svg-4.4.0.ebuild b/x11-libs/qt-svg/qt-svg-4.4.0.ebuild
deleted file mode 100644
index 0e83ef7af9c7..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.4.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.4.0.ebuild,v 1.5 2008/06/13 23:25:06 ingmar Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-gui-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QCONFIG_ADD="svg"
-QCONFIG_DEFINE="QT_SVG"
-QT4_TARGET_DIRECTORIES="
-src/svg
-src/plugins/imageformats/svg
-src/plugins/iconengines/svgiconengine"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-src_compile() {
- local myconf
- myconf="${myconf} -svg -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-glib -no-opengl"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-svg/qt-svg-4.4.1.ebuild b/x11-libs/qt-svg/qt-svg-4.4.1.ebuild
deleted file mode 100644
index 69103ae3d291..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.4.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.4.1.ebuild,v 1.1 2008/08/11 13:10:37 yngwin Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-gui-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QCONFIG_ADD="svg"
-QCONFIG_DEFINE="QT_SVG"
-QT4_TARGET_DIRECTORIES="
-src/svg
-src/plugins/imageformats/svg
-src/plugins/iconengines/svgiconengine"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-src_compile() {
- local myconf
- myconf="${myconf} -svg -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-glib -no-opengl"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 59b809eafbe8..d9e2f06bb160 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-test
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.12 2008/09/19 00:17:34 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.13 2009/01/06 15:19:41 yngwin Exp $
+
+ 06 Jan 2009; Ben de Groot <yngwin@gentoo.org> -qt-test-4.4.0.ebuild,
+ -qt-test-4.4.1.ebuild:
+ Clean out old ebuilds
*qt-test-4.4.2 (19 Sep 2008)
diff --git a/x11-libs/qt-test/qt-test-4.4.0.ebuild b/x11-libs/qt-test/qt-test-4.4.0.ebuild
deleted file mode 100644
index cf9db1d40f88..000000000000
--- a/x11-libs/qt-test/qt-test-4.4.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.4.0.ebuild,v 1.5 2008/06/13 23:25:39 ingmar Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The testing framework module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-core-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/testlib"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-src_compile() {
- local myconf
- myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-glib -no-opengl -no-svg"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-test/qt-test-4.4.1.ebuild b/x11-libs/qt-test/qt-test-4.4.1.ebuild
deleted file mode 100644
index 4bf6867d73e1..000000000000
--- a/x11-libs/qt-test/qt-test-4.4.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.4.1.ebuild,v 1.1 2008/08/11 13:12:06 yngwin Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The testing framework module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-core-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/testlib"
-QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
-
-src_compile() {
- local myconf
- myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-glib -no-opengl -no-svg"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 063f2b16d2c7..4fc3374213ec 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-webkit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.14 2008/10/25 21:03:11 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.15 2009/01/06 15:22:06 yngwin Exp $
+
+ 06 Jan 2009; Ben de Groot <yngwin@gentoo.org> -qt-webkit-4.4.0.ebuild,
+ -qt-webkit-4.4.1.ebuild:
+ Clean out old ebuilds
25 Oct 2008; Mike Frysinger <vapier@gentoo.org> qt-webkit-4.4.2.ebuild:
Add -mminimal-toc to workaround ppc64 compiler issues #241900.
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.0.ebuild
deleted file mode 100644
index e20e90becaad..000000000000
--- a/x11-libs/qt-webkit/qt-webkit-4.4.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.0.ebuild,v 1.4 2008/06/13 23:26:10 ingmar Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The Webkit module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-gui-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
-QT4_EXTRACT_DIRECTORIES="src/3rdparty/webkit src/3rdparty/sqlite
-tools/designer/src/plugins/qwebview"
-QCONFIG_ADD="webkit"
-QCONFIG_DEFINE="QT_WEBKIT"
-
-src_compile() {
- local myconf
- myconf="${myconf} -webkit"
-
- qt4-build_src_compile
-}
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.1.ebuild
deleted file mode 100644
index 29b2c19f0830..000000000000
--- a/x11-libs/qt-webkit/qt-webkit-4.4.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.1.ebuild,v 1.2 2008/08/27 14:43:46 armin76 Exp $
-
-EAPI="1"
-inherit qt4-build
-
-DESCRIPTION="The Webkit module for the Qt toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-LICENSE="|| ( GPL-3 GPL-2 )"
-SLOT="4"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 -sparc ~x86"
-IUSE=""
-
-DEPEND="~x11-libs/qt-gui-${PV}
- !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
-QT4_EXTRACT_DIRECTORIES="src/3rdparty/webkit src/3rdparty/sqlite
-tools/designer/src/plugins/qwebview"
-QCONFIG_ADD="webkit"
-QCONFIG_DEFINE="QT_WEBKIT"
-
-src_compile() {
- local myconf
- myconf="${myconf} -webkit"
-
- qt4-build_src_compile
-}