summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/radvd/radvd-0.7.1.ebuild17
-rw-r--r--net-misc/radvd/radvd-0.7.2.ebuild17
-rw-r--r--net-misc/rwbs/rwbs-0.27.ebuild17
-rw-r--r--net-misc/shorewall/shorewall-1.3.9b.ebuild24
-rw-r--r--net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild46
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild19
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.6.ebuild23
7 files changed, 84 insertions, 79 deletions
diff --git a/net-misc/radvd/radvd-0.7.1.ebuild b/net-misc/radvd/radvd-0.7.1.ebuild
index 65b8da33fbda..7c393ee7eca5 100644
--- a/net-misc/radvd/radvd-0.7.1.ebuild
+++ b/net-misc/radvd/radvd-0.7.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.1.ebuild,v 1.2 2002/11/02 13:53:55 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.1.ebuild,v 1.3 2002/11/30 21:02:23 vapier Exp $
-IUSE=""
DESCRIPTION="Linux IPv6 Router Advertisement Daemon (radvd)"
HOMEPAGE="http://v6web.litech.org/radvd/"
SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
-DEPEND="virtual/glibc
- virtual/kernel"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
+DEPEND="virtual/glibc
+ virtual/kernel"
+
pkg_preinst() {
if ! groupmod radvd; then
groupadd -g 75 radvd || die "problem adding group radvd"
@@ -27,11 +28,11 @@ pkg_preinst() {
src_compile() {
econf --libexecdir=/usr/lib/radvd \
--with-pidfile=/var/run/radvd/radvd.pid \
- --sysconfdir=/etc/radvd || die "./configure failed"
+ --sysconfdir=/etc/radvd
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc CHANGES COPYRIGHT INTRO.html README TODO
@@ -41,12 +42,12 @@ src_install () {
exeinto /etc/init.d
doexe ${FILESDIR}/radvd
- mkdir -p ${D}/var/run/radvd
+ dodir /var/run/radvd
fowners radvd.radvd /var/run/radvd
fperms 755 /var/run/radvd
}
-pkg_postinst () {
+pkg_postinst() {
einfo To make it work you have to configure /etc/radvd/radvd.conf and put
einfo the line net.ipv6.conf.all.forwarding = 1 in sysctl.conf or just run
einfo sysctl -w net.ipv6.conf.all.forwarding=1 in your firewallscripts before
diff --git a/net-misc/radvd/radvd-0.7.2.ebuild b/net-misc/radvd/radvd-0.7.2.ebuild
index a9f020042270..3fb73c684f4d 100644
--- a/net-misc/radvd/radvd-0.7.2.ebuild
+++ b/net-misc/radvd/radvd-0.7.2.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.2.ebuild,v 1.1 2002/11/26 00:52:47 edolnx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.2.ebuild,v 1.2 2002/11/30 21:03:03 vapier Exp $
-IUSE=""
DESCRIPTION="Linux IPv6 Router Advertisement Daemon (radvd)"
HOMEPAGE="http://v6web.litech.org/radvd/"
SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
-DEPEND="virtual/glibc
- virtual/kernel"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+DEPEND="virtual/glibc
+ virtual/kernel"
+
pkg_preinst() {
if ! groupmod radvd; then
groupadd -g 75 radvd || die "problem adding group radvd"
@@ -27,11 +28,11 @@ pkg_preinst() {
src_compile() {
econf --libexecdir=/usr/lib/radvd \
--with-pidfile=/var/run/radvd/radvd.pid \
- --sysconfdir=/etc/radvd || die "./configure failed"
+ --sysconfdir=/etc/radvd
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc CHANGES COPYRIGHT INTRO.html README TODO
@@ -41,12 +42,12 @@ src_install () {
exeinto /etc/init.d
doexe ${FILESDIR}/radvd
- mkdir -p ${D}/var/run/radvd
+ dodir /var/run/radvd
fowners radvd.radvd /var/run/radvd
fperms 755 /var/run/radvd
}
-pkg_postinst () {
+pkg_postinst() {
einfo To make it work you have to configure /etc/radvd/radvd.conf and put
einfo the line net.ipv6.conf.all.forwarding = 1 in sysctl.conf or just run
einfo sysctl -w net.ipv6.conf.all.forwarding=1 in your firewallscripts before
diff --git a/net-misc/rwbs/rwbs-0.27.ebuild b/net-misc/rwbs/rwbs-0.27.ebuild
index 3e8f23b876dd..b55b030e297c 100644
--- a/net-misc/rwbs/rwbs-0.27.ebuild
+++ b/net-misc/rwbs/rwbs-0.27.ebuild
@@ -2,29 +2,30 @@
# Distributed under the terms of the GNU General Public License v2
# $Header:
-S=${WORKDIR}
-
DESCRIPTION="Roger Wilco base station"
HOMEPAGE="http://rogerwilco.gamespy.com/"
SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+
KEYWORDS="~x86"
+SLOT="0"
+
# Everything is statically linked
DEPEND=""
-IUSE=""
-src_install () {
- cd ${WORKDIR}
+S=${WORKDIR}
+
+src_install() {
dodoc README.TXT CHANGES.TXT LICENSE.TXT
dobin ${S}/rwbs ${S}/run_rwbs
rm -f ${S}/rwbs ${S}/run_rwbs
# Put distribution into /usr/share/rwbs
- mkdir -p ${D}/usr/share/rwbs/
+ dodir /usr/share/rwbs/
mv * ${D}/usr/share/rwbs/
# Do conf script
- mkdir -p ${D}/etc/conf.d/
+ dodir /etc/conf.d/
cat > ${D}/etc/conf.d/rwbs <<EOF
# Roger Wilco base station configuration
#
@@ -50,7 +51,7 @@ RWBS_OPTS='-n "Gentoo Linux"'
EOF
# do init script
- mkdir -p ${D}/etc/init.d/
+ dodir /etc/init.d/
cat > ${D}/etc/init.d/rwbs <<EOF
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
diff --git a/net-misc/shorewall/shorewall-1.3.9b.ebuild b/net-misc/shorewall/shorewall-1.3.9b.ebuild
index 6605e56e4c2f..8a969a7d11c3 100644
--- a/net-misc/shorewall/shorewall-1.3.9b.ebuild
+++ b/net-misc/shorewall/shorewall-1.3.9b.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
+# Distributed under the terms of the GNU General Public License v2
# $Header: /home/cvsroot/gentoo-x86/net-misc/shorewall/shorewall-1..3.9b.ebuild
-MY_P=shorewall-1.3.9b
-S=${WORKDIR}/${MY_P}
DESCRIPTION="Full state iptables firewall"
-SRC_URI="http://www.shorewall.net/pub/shorewall/${MY_P}.tgz"
-HOMEPAGE="http://www.shorewall.net"
+SRC_URI="http://www.shorewall.net/pub/shorewall/${P}.tgz"
+HOMEPAGE="http://www.shorewall.net/"
+
LICENSE="GPL"
KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
SLOT="0"
@@ -15,19 +14,20 @@ DEPEND="virtual/glibc
sys-apps/iptables
sys-apps/iproute"
-src_install () {
- mkdir -p ${D}/etc/init.d
- mkdir -p ${D}/var/state
+src_install() {
+ dodir /etc/init.d
+ dodir /var/state
PREFIX=${D} ./install.sh || die
rm -f ${D}/usr/lib/shorewall/firewall
cp ${D}/etc/init.d/shorewall ${D}/usr/lib/shorewall/firewall
rm -rf ${D}/etc/init.d
-
-exeinto /etc/init.d
+
+ exeinto /etc/init.d
newexe ${FILESDIR}/shorewall shorewall
}
+
pkg_postinst() {
- echo -e "\e[32;01m Read the documentatition from http://www.shorewall.net \033[0m"
- echo -e "\e[32;01m and edit the files in /etc/shorewall before starting the firewall \033[0m"
+ einfo "Read the documentatition from http://www.shorewall.net/"
+ einfo "and edit the files in /etc/shorewall before starting the firewall"
echo
}
diff --git a/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild b/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild
index 2741776a77f0..bc8268b0f76c 100644
--- a/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild
+++ b/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild
@@ -1,33 +1,45 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild,v 1.5 2002/10/04 06:15:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taylor-uucp/taylor-uucp-1.06.2.ebuild,v 1.6 2002/11/30 20:58:38 vapier Exp $
-A="uucp-${PV}.tar.gz"
S=${WORKDIR}/uucp-1.06.1 # This should be a .2 bug the package is messed
DESCRIPTION="Taylor UUCP"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/uucp/${A}"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/uucp/uucp-${PV}.tar.gz"
HOMEPAGE="http://www.airs.com/ian/uucp.html"
+
KEYWORDS="x86 sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/glibc"
-src_compile ()
-{
- ./configure --prefix=/usr --host=${CHOST}
- make sbindir=/usr/sbin bindir=/usr/bin man1dir=/usr/share/man/man1 man8dir=/usr/share/man/man8 newconfigdir=/etc/uucp infodir=/usr/share/info || die
+src_compile() {
+ econf
+ make \
+ sbindir=/usr/sbin \
+ bindir=/usr/bin \
+ man1dir=/usr/share/man/man1 \
+ man8dir=/usr/share/man/man8 \
+ newconfigdir=/etc/uucp \
+ infodir=/usr/share/info \
+ || die
}
-src_install ()
-{
- mkdir -p ${D}/usr/share/man/man1
- mkdir -p ${D}/usr/share/man/man8
- mkdir -p ${D}/usr/share/info
- mkdir -p ${D}/etc/uucp
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/usr/sbin
- make prefix=${D}/usr sbindir=${D}/usr/sbin bindir=${D}/usr/bin man1dir=${D}/usr/share/man/man1 man8dir=${D}/usr/share/man/man8 newconfigdir=${D}/etc/uucp infodir=${D}/usr/share/info install || die
- make prefix=${D}/usr sbindir=${D}/usr/sbin bindir=${D}/usr/bin man1dir=${D}/usr/share/man/man1 man8dir=${D}/usr/share/man/man8 newconfigdir=${D}/etc/uucp infodir=${D}/usr/share/info install-info || die
+src_install() {
+ dodir /usr/share/man/man1
+ dodir /usr/share/man/man8
+ dodir /usr/share/info
+ dodir /etc/uucp
+ dodir /usr/bin
+ dodir /usr/sbin
+ make \
+ prefix=${D}/usr \
+ sbindir=${D}/usr/sbin \
+ bindir=${D}/usr/bin \
+ man1dir=${D}/usr/share/man/man1 \
+ man8dir=${D}/usr/share/man/man8 \
+ newconfigdir=${D}/etc/uucp \
+ infodir=${D}/usr/share/info \
+ install install-info || die
dodoc COPYING ChangeLog MANIFEST NEWS README TODO
}
diff --git a/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild b/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild
index 948e2bf3ebdb..6d140a96abab 100644
--- a/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild
+++ b/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild
@@ -8,37 +8,32 @@ S="${WORKDIR}/vnc_unixsrc"
DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
HOMEPAGE="http://www.tightvnc.com"
+
KEYWORDS="x86 ppc sparc sparc64 alpha"
LICENSE="GPL-2"
SLOT="0"
+
DEPEND="virtual/glibc
>=x11-base/xfree-4.1.0
>=sys-devel/perl-5.6.1
~media-libs/jpeg-6b
>=sys-libs/zlib-1.1.4"
-RDEPEND=$DEPEND
-
src_compile() {
-
- cd ${S}
xmkmf || die
make World || die
cd Xvnc
make World || die
-
}
src_install() {
-
- cd ${S}
- mkdir -p ${D}/usr/man
- mkdir -p ${D}/usr/man/man1
- mkdir -p ${D}/usr/bin
+ dodir /usr/man
+ dodir /usr/man/man1
+ dodir /usr/bin
# fix the web based interface, it needs the java class files
- mkdir -p ${D}/usr/share/tightvnc
- mkdir -p ${D}/usr/share/tightvnc/classes
+ dodir /usr/share/tightvnc
+ dodir /usr/share/tightvnc/classes
insinto /usr/share/tightvnc/classes ; doins classes/*
# and then patch vncserver to point to /usr/share/tightvnc/classes
diff --git a/net-misc/tightvnc/tightvnc-1.2.6.ebuild b/net-misc/tightvnc/tightvnc-1.2.6.ebuild
index 19e1bd5e95dd..0173257d7e2d 100644
--- a/net-misc/tightvnc/tightvnc-1.2.6.ebuild
+++ b/net-misc/tightvnc/tightvnc-1.2.6.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.6.ebuild,v 1.2 2002/10/09 21:52:10 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.6.ebuild,v 1.3 2002/11/30 21:01:11 vapier Exp $
S="${WORKDIR}/vnc_unixsrc"
DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
-HOMEPAGE="http://www.tightvnc.com"
+HOMEPAGE="http://www.tightvnc.com/"
+
KEYWORDS="x86 ppc alpha"
LICENSE="GPL-2"
SLOT="0"
+
DEPEND="virtual/x11
sys-devel/perl
~media-libs/jpeg-6b
sys-libs/zlib"
-RDEPEND=$DEPEND
-
src_unpack() {
unpack ${A} ; cd ${S}
#patch <${FILESDIR}/tightvnc-gentoo.diff || die
@@ -27,26 +27,21 @@ src_unpack() {
}
src_compile() {
-
- cd ${S}
xmkmf || die
make World || die
cd Xvnc
./configure || die
make || die
-
}
src_install() {
-
- cd ${S}
- mkdir -p ${D}/usr/man
- mkdir -p ${D}/usr/man/man1
- mkdir -p ${D}/usr/bin
+ dodir /usr/man
+ dodir /usr/man/man1
+ dodir /usr/bin
# fix the web based interface, it needs the java class files
- mkdir -p ${D}/usr/share/tightvnc
- mkdir -p ${D}/usr/share/tightvnc/classes
+ dodir /usr/share/tightvnc
+ dodir /usr/share/tightvnc/classes
insinto /usr/share/tightvnc/classes ; doins classes/*
# and then patch vncserver to point to /usr/share/tightvnc/classes