summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/springgraph/ChangeLog7
-rw-r--r--media-gfx/springgraph/Manifest10
-rw-r--r--media-gfx/springgraph/files/digest-springgraph-882
-rw-r--r--media-gfx/springgraph/springgraph-88.ebuild38
4 files changed, 52 insertions, 5 deletions
diff --git a/media-gfx/springgraph/ChangeLog b/media-gfx/springgraph/ChangeLog
index fa69e19e8722..cd45aa53c824 100644
--- a/media-gfx/springgraph/ChangeLog
+++ b/media-gfx/springgraph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/springgraph
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/springgraph/ChangeLog,v 1.12 2005/05/09 00:31:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/springgraph/ChangeLog,v 1.13 2005/12/12 05:40:49 robbat2 Exp $
+
+*springgraph-88 (12 Dec 2005)
+
+ 12 Dec 2005; Robin H. Johnson <robbat2@gentoo.org> +springgraph-88.ebuild:
+ Version bump.
08 May 2005; Aron Griffis <agriffis@gentoo.org> springgraph-82.ebuild:
stable on ia64
diff --git a/media-gfx/springgraph/Manifest b/media-gfx/springgraph/Manifest
index 67fdc5313e38..1071ac3d1c22 100644
--- a/media-gfx/springgraph/Manifest
+++ b/media-gfx/springgraph/Manifest
@@ -1,6 +1,8 @@
-MD5 ad3e6e2666399656220e675a0af6141d springgraph-79.ebuild 705
-MD5 b5459e16203163aa5ebd53bd0801251d springgraph-82.ebuild 927
-MD5 544d97b39cdb2b59f2bf6a31fd050f74 ChangeLog 1453
-MD5 33972e24d3f8c3621bd32c36ba6e8b6c metadata.xml 716
+MD5 005d13182c76c14fd0878b6ff984826a ChangeLog 1577
MD5 b0879467842149fda0eb7ccea27b6a64 files/digest-springgraph-79 61
MD5 263d583a99ac0787161b08250a2017b1 files/digest-springgraph-82 140
+MD5 86c8523e00d94571f9c5288a204e3642 files/digest-springgraph-88 130
+MD5 33972e24d3f8c3621bd32c36ba6e8b6c metadata.xml 716
+MD5 ad3e6e2666399656220e675a0af6141d springgraph-79.ebuild 705
+MD5 b5459e16203163aa5ebd53bd0801251d springgraph-82.ebuild 927
+MD5 a71c628c5c2eb44c3dd0ccf5db2271b1 springgraph-88.ebuild 1005
diff --git a/media-gfx/springgraph/files/digest-springgraph-88 b/media-gfx/springgraph/files/digest-springgraph-88
new file mode 100644
index 000000000000..31296047e09b
--- /dev/null
+++ b/media-gfx/springgraph/files/digest-springgraph-88
@@ -0,0 +1,2 @@
+MD5 12b52e4fcf7e8bf138773f2bde014895 springgraph.pl.88 29818
+MD5 dc3704fc47316e684be79d4ee0aa2b1c springgraph_0.82-5.diff.gz 3110
diff --git a/media-gfx/springgraph/springgraph-88.ebuild b/media-gfx/springgraph/springgraph-88.ebuild
new file mode 100644
index 000000000000..1f77f6cf97c5
--- /dev/null
+++ b/media-gfx/springgraph/springgraph-88.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/springgraph/springgraph-88.ebuild,v 1.1 2005/12/12 05:40:49 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Generate spring graphs from graphviz input files"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
+MY_PV="0.${PV}"
+MY_P="${PN}_${MY_PV}"
+SRC_FILE="${MY_P}.orig.tar.gz"
+SRC_DEBIAN_PATCH="${PN}_0.82-5.diff.gz"
+SRC_URI="http://www.chaosreigns.com/code/springgraph/dl/${PN}.pl.${PV}
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-perl/GD"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ mkdir -p ${S}
+ cp ${DISTDIR}/${PN}.pl.${PV} ${S}/${PN}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${SRC_DEBIAN_PATCH}
+}
+
+src_compile() {
+ # nothing to do
+ :
+}
+
+src_install() {
+ into /usr
+ dobin ${PN}
+ doman debian/${PN}.1
+}