summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/xloadimage/Manifest12
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r4.ebuild26
2 files changed, 24 insertions, 14 deletions
diff --git a/media-gfx/xloadimage/Manifest b/media-gfx/xloadimage/Manifest
index f87310a361b4..584c19742dfb 100644
--- a/media-gfx/xloadimage/Manifest
+++ b/media-gfx/xloadimage/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 9f60dbdf2bd35b67048fc919417f73de ChangeLog 6141
MD5 1e91f350f870e196e1f181a27f3fd1ab files/digest-xloadimage-4.1-r4 140
MD5 fb91a22d37e6c6db534f1dc81add707e files/xloadimage-4.1-endif.patch 321
@@ -5,4 +8,11 @@ MD5 c411c977cc7ae79dd96aad933980dbb2 files/xloadimage-4.1-include-errno_h.patch
MD5 9208b10866e00f1e47bb12a7f8bec04a files/xloadimage-4.1-zio-shell-meta-char.diff 1372
MD5 49ea6a01c79f1540896bd264c3606cb3 files/xloadimage-gentoo.patch 8956
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
-MD5 4be205332400a34b50b65202e55cae02 xloadimage-4.1-r4.ebuild 2302
+MD5 d455ac1cadb4d624592e07b696bf2c9c xloadimage-4.1-r4.ebuild 2330
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDzslt2+ySkm8kpY0RAm4wAJ9WykcODmNC7l68K8jCnEYmSt+O7gCePfel
+DPUcVGUd9LC+nY7i6VgwCzg=
+=JLjE
+-----END PGP SIGNATURE-----
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
index f577b744ff1d..5707669a9e7e 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild,v 1.13 2005/12/30 23:56:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild,v 1.14 2006/01/18 23:02:05 vapier Exp $
inherit alternatives eutils flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="ftp://ftp.x.org/R5contrib/${MY_P}.tar.gz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 sh sparc x86"
IUSE="tiff jpeg png"
RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
@@ -25,19 +25,19 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${WORKDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-zio-shell-meta-char.diff
- epatch ${FILESDIR}/${P}-endif.patch
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-zio-shell-meta-char.diff
+ epatch "${FILESDIR}"/${P}-endif.patch
# Do not define errno extern, but rather include errno.h
# <azarah@gentoo.org> (1 Jan 2003)
- epatch ${FILESDIR}/${P}-include-errno_h.patch
+ epatch "${FILESDIR}"/${P}-include-errno_h.patch
- epatch "${FILESDIR}/xloadimage-gentoo.patch"
+ epatch "${FILESDIR}"/xloadimage-gentoo.patch
sed -i "s:OPT_FLAGS=:OPT_FLAGS=$CFLAGS:" Make.conf
- sed -i "s:^#include <varargs.h>:#include <stdarg.h>:" ${S}/rlelib.c
+ sed -i "s:^#include <varargs.h>:#include <stdarg.h>:" "${S}"/rlelib.c
# On FreeBSD systems malloc.h is a false header asking for fixes.
# On MacOSX it would require malloc/malloc.h
@@ -50,12 +50,12 @@ src_unpack() {
done
fi
- chmod +x ${S}/configure
+ chmod +x "${S}"/configure
}
src_install() {
- dobin xloadimage
- dobin uufilter
+ dobin xloadimage || die
+ dobin uufilter || die
insinto /etc/X11
doins xloadimagerc