summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/cksfv/cksfv-1.3.12.ebuild')
-rw-r--r--app-arch/cksfv/cksfv-1.3.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.12.ebuild b/app-arch/cksfv/cksfv-1.3.12.ebuild
new file mode 100644
index 000000000000..701f5a559cbc
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cksfv/cksfv-1.3.12.ebuild,v 1.1 2007/11/17 23:15:35 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ emake install || die
+ dodoc ChangeLog README TODO
+}