summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/smarteiffel/smarteiffel-2.2.ebuild')
-rw-r--r--dev-lang/smarteiffel/smarteiffel-2.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-lang/smarteiffel/smarteiffel-2.2.ebuild b/dev-lang/smarteiffel/smarteiffel-2.2.ebuild
index 7d18f0ffeb13..80fcfb3e667b 100644
--- a/dev-lang/smarteiffel/smarteiffel-2.2.ebuild
+++ b/dev-lang/smarteiffel/smarteiffel-2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/smarteiffel-2.2.ebuild,v 1.2 2007/07/13 06:25:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/smarteiffel-2.2.ebuild,v 1.3 2007/08/22 21:29:50 truedfx Exp $
-inherit toolchain-funcs multilib
+inherit flag-o-matic toolchain-funcs multilib
MY_PV="${PV/./-}"
S="${WORKDIR}/SmartEiffel"
@@ -21,6 +21,11 @@ DEPEND="tcc? ( >=dev-lang/tcc-0.9.14 )"
# Destination directory to hold most of the SmartEiffel distribution.
SE_DIR="/usr/$(get_libdir)/SmartEiffel"
+pkg_setup() {
+ # bug #189782
+ append-flags $(test-flags -fno-strict-overflow)
+}
+
src_compile() {
use tcc && CFLAGS=""
use tcc && COMPILER=tcc || COMPILER="$(tc-getCC)"