summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild')
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild
new file mode 100644
index 000000000000..38973cb8f9d0
--- /dev/null
+++ b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild,v 1.1 2008/02/26 16:41:25 armin76 Exp $
+
+inherit php-pear-lib-r1 depend.php
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/php-5.2.0"
+RDEPEND="${DEPEND}
+ >=dev-php/PEAR-Log-1.8.7-r1"
+
+S="${WORKDIR}/propel_runtime-${PV/_/}"
+
+pkg_setup() {
+ # We need PDO and a few other things
+ require_php_with_use pdo reflection spl xml xsl
+}