summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-poppler/python-poppler-0.10.0.ebuild')
-rw-r--r--dev-python/python-poppler/python-poppler-0.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-poppler/python-poppler-0.10.0.ebuild b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
new file mode 100644
index 000000000000..0e37fbf9e161
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.10.0.ebuild,v 1.1 2009/06/01 13:58:47 loki_val Exp $
+
+EAPI=2
+
+inherit libtool
+
+DESCRIPTION="Python bindings to the Poppler PDF library."
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/poppler-python"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/pypoppler-${PV}"
+
+RDEPEND=">=virtual/poppler-glib-0.10.0
+ >=dev-python/pygobject-2.11.3
+ >=dev-python/pygtk-2.10.0
+ >=dev-python/pycairo-1.2.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
+}
+