summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/ChangeLog6
-rw-r--r--dev-tcltk/thread/Manifest4
-rw-r--r--dev-tcltk/thread/thread-2.6.1.ebuild14
3 files changed, 15 insertions, 9 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index df33738e6b2a..2c39db0b0d7b 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/thread
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.2 2005/07/03 01:20:12 matsuu Exp $
+
+ 03 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> thread-2.6.1.ebuild:
+ Fixed with gdbm cofigure issue. Bug 97738.
+ Fixed DISCRIPTION. Bug 97739.
*thread-2.6.1 (02 Jul 2005)
diff --git a/dev-tcltk/thread/Manifest b/dev-tcltk/thread/Manifest
index 4c8704484369..d994eb84611e 100644
--- a/dev-tcltk/thread/Manifest
+++ b/dev-tcltk/thread/Manifest
@@ -1,4 +1,4 @@
-MD5 2a4375267ac1120a3b1a12f2318567da thread-2.6.1.ebuild 1033
-MD5 21fea1bf20a5c6843e928f92ab9c1c47 ChangeLog 352
+MD5 2ecd1ec578a13592b623d8ab6b58c5a0 thread-2.6.1.ebuild 1076
+MD5 b68310e6e2e92adc40b42a5b6d1d7955 ChangeLog 500
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 9b4c86b16329dae30cdefd49b1e31f68 files/digest-thread-2.6.1 63
diff --git a/dev-tcltk/thread/thread-2.6.1.ebuild b/dev-tcltk/thread/thread-2.6.1.ebuild
index 98cb09d318bd..0436f27ee3d2 100644
--- a/dev-tcltk/thread/thread-2.6.1.ebuild
+++ b/dev-tcltk/thread/thread-2.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.1 2005/07/02 15:20:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.2 2005/07/03 01:20:12 matsuu Exp $
inherit eutils
-DESCRIPTION="This is a sample skeleton ebuild file"
+DESCRIPTION="the Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
@@ -27,10 +27,12 @@ pkg_setup() {
}
src_compile() {
- econf \
- --with-threads \
- --with-tclinclude=/usr/include \
- `use_with gdbm` || die "econf failed"
+ local myconf="--with-threads --with-tclinclude=/usr/include"
+
+ if use gdbm ; then
+ myconf="${myconf} --with-gdbm"
+ fi
+ econf ${myconf} || die "econf failed"
emake || die "emake failed"
}