summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/glxquake-bin')
-rw-r--r--games-fps/glxquake-bin/ChangeLog8
-rw-r--r--games-fps/glxquake-bin/files/digest-glxquake-bin-0-r13
-rw-r--r--games-fps/glxquake-bin/glxquake-bin-0-r1.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/games-fps/glxquake-bin/ChangeLog b/games-fps/glxquake-bin/ChangeLog
index 8f45e6cdccbc..f5c7541f358f 100644
--- a/games-fps/glxquake-bin/ChangeLog
+++ b/games-fps/glxquake-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/glxquake-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/glxquake-bin/ChangeLog,v 1.3 2006/03/31 03:24:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/glxquake-bin/ChangeLog,v 1.4 2006/09/10 10:49:21 tupone Exp $
+
+*glxquake-bin-0-r1 (10 Sep 2006)
+
+ 10 Sep 2006; <tupone@gentoo.org> -glxquake-bin-0.ebuild,
+ +glxquake-bin-0-r1.ebuild:
+ Add instructions for post install actions. Bug #135066 by Kimmo Sundqvist
31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> glxquake-bin-0.ebuild:
Fixed up the dependencies, ported to modular X, and closing bug #123561.
diff --git a/games-fps/glxquake-bin/files/digest-glxquake-bin-0-r1 b/games-fps/glxquake-bin/files/digest-glxquake-bin-0-r1
new file mode 100644
index 000000000000..20402c7eef39
--- /dev/null
+++ b/games-fps/glxquake-bin/files/digest-glxquake-bin-0-r1
@@ -0,0 +1,3 @@
+MD5 3959bd8193cb0f1c3b2e6f3b9e4a3df7 glxquake.tar.gz 221435
+RMD160 18fc6836e9604673ac9867e94d289c43a6745005 glxquake.tar.gz 221435
+SHA256 f4f1b591597b7b1195101f49bea1dfc784cda0c6590b9eb50bbcda9ef2131b60 glxquake.tar.gz 221435
diff --git a/games-fps/glxquake-bin/glxquake-bin-0-r1.ebuild b/games-fps/glxquake-bin/glxquake-bin-0-r1.ebuild
new file mode 100644
index 000000000000..a88148eb0999
--- /dev/null
+++ b/games-fps/glxquake-bin/glxquake-bin-0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/glxquake-bin/glxquake-bin-0-r1.ebuild,v 1.1 2006/09/10 10:49:21 tupone Exp $
+
+inherit games
+
+DESCRIPTION="a binary that works with every 3D-graphics-card that supports the glx X-extension"
+HOMEPAGE="http://mfcn.ilo.de/glxquake/"
+SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ x86? (
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libdrm
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}/glxquake
+
+src_install() {
+ dogamesbin glquake || die "dogamesbin failed"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To play with it, create a subdirectory called id1"
+ einfo "Copy the pak0.pak, and eventually pak1.pak into this subdirectory"
+ einfo "You can eventually get pak0.pak emerging games-fps/quake1-demodata"
+ einfo "The file pak0.pak will be on the ${GAMES_DATADIR}/quake1/demo/"
+ einfo "You can now run glxquake by executing glquake"
+}