summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kcheckpass/kcheckpass-4.11.4.ebuild')
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.4.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.4.ebuild
new file mode 100644
index 000000000000..6f49142dea7d
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.4.ebuild,v 1.1 2013/12/03 22:36:07 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}