summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/flphoto/flphoto-1.3.1.ebuild')
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-gfx/flphoto/flphoto-1.3.1.ebuild b/media-gfx/flphoto/flphoto-1.3.1.ebuild
index bf9c84bb4590..99786625cc33 100644
--- a/media-gfx/flphoto/flphoto-1.3.1.ebuild
+++ b/media-gfx/flphoto/flphoto-1.3.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.2 2008/11/14 18:54:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.3 2008/11/23 20:25:34 halcy0n Exp $
EAPI=1
+inherit eutils
+
DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
@@ -17,6 +19,12 @@ DEPEND=">=x11-libs/fltk-1.1.4:1.1
cups? ( net-print/cups )
gphoto2? ( media-gfx/gphoto2 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
+}
+
src_compile() {
econf --with-docdir=/usr/share/doc/${P} || die
emake -j1 || die