summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-3.70.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.70.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-3.70.ebuild b/net-analyzer/nmap/nmap-3.70.ebuild
new file mode 100644
index 000000000000..83b639d29560
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.70.ebuild,v 1.1 2004/09/01 11:37:07 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64"
+IUSE="gtk gnome"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+ econf `use_with gtk nmapfe` || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall nmapdatadir=${D}/usr/share/nmap install || die
+ use gnome || rm -rf ${D}/usr/share/gnome/
+
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+}